A + B Problem II

该博客主要介绍了一个用于处理大整数相加问题的算法实现,输入为两个非常大的正整数,通过字符串形式读取并进行计算。算法采用逐位相加并处理进位的方式,确保了大整数的正确相加。样例输入和输出展示了算法的正确性。
摘要由CSDN通过智能技术生成

E - A + B Problem II

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

参考代码:

#include<stdio.h>
#include<string.h>
int main()
{
	int t,i,k,x=0,j,max;
	char a[1100],b[1100];
	scanf("%d",&t);
	getchar();
	while(t--)
	{
		int c[1100]={0};
		scanf("%s",&a);
		x++;
		getchar();
		scanf("%s",&b);
		getchar();
		j=strlen(a);
		k=strlen(b);
		max=j<k?k:j; 
		j--;
		k--;
		for(i=0;i<max;i++)
		{
			if(j>=0)
				c[i]+=a[j--]-'0';
			if(k>=0)
				c[i]+=b[k--]-'0';
			if(c[i]>9)
			{
				c[i+1]+=c[i]/10;
				c[i]%=10;
			}
		}
		printf("Case %d:\n",x);
		printf("%s + %s = ",a,b);
		for(i=max+1;i>=0;i--)
		{
			if(c[i]>0)
			{
				for(;i>=0;i--)
				{
					printf("%d",c[i]);
				}
				break;
			}
		}
		printf("\n");
		if(t>0)
			printf("\n"); 
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值