E - A + B Problem II
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
参考代码:
#include<stdio.h>
#include<string.h>
int main()
{
int t,i,k,x=0,j,max;
char a[1100],b[1100];
scanf("%d",&t);
getchar();
while(t--)
{
int c[1100]={0};
scanf("%s",&a);
x++;
getchar();
scanf("%s",&b);
getchar();
j=strlen(a);
k=strlen(b);
max=j<k?k:j;
j--;
k--;
for(i=0;i<max;i++)
{
if(j>=0)
c[i]+=a[j--]-'0';
if(k>=0)
c[i]+=b[k--]-'0';
if(c[i]>9)
{
c[i+1]+=c[i]/10;
c[i]%=10;
}
}
printf("Case %d:\n",x);
printf("%s + %s = ",a,b);
for(i=max+1;i>=0;i--)
{
if(c[i]>0)
{
for(;i>=0;i--)
{
printf("%d",c[i]);
}
break;
}
}
printf("\n");
if(t>0)
printf("\n");
}
return 0;
}