PTA甲级 1031 Hello World for U(C++)

准大二小白在学技术的同时每天至少一道算法题,以此督促自己,共勉!

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1​ characters, then left to right along the bottom line with n2​ characters, and finally bottom-up along the vertical line with n3​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1​=n3​=max { k | k≤n2​ for all 3≤n2​≤N } with n1​+n2​+n3​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<bits/stdc++.h>
using namespace std;
string str;
char G[100][80];
int main(){
    cin>>str;
    int totalLen=str.length();
    int len=(str.length()+2)/3,bottomLen=totalLen-2*len;
    int i,j,k,temp=0;
    // cout<<totalLen<<endl<<len<<endl<<bottomLen<<endl;
    for(i=0;i<len;i++){
        G[i][0]=str[temp++];
        // cout<<i<<" "<<G[i][0]<<endl;
    }
    i--;
    // cout<<" ------"<<endl;
    for(j=1;j<1+bottomLen;j++){
        G[i][j]=str[temp++];
        // cout<<"i= "<<i<<"j = "<<j<<"  "<<G[i][j]<<endl;
    }
        // cout<<" ------"<<endl;
    for(k=i;k>=0;k--){
        G[k][j]=str[temp++];
        // cout<<G[k][j]<<endl;
         // cout<<"k= "<<k<<"j = "<<j<<"  "<<G[k][j]<<endl;
    }
    // printf("%c",G[0][4]);
    for(int p=0;p<=i;p++){
        for(int q=0;q<2+bottomLen;q++){
            // printf("p==%d\n",p);
            // printf("q==%d\n",q);
            if(G[p][q]!='\0')
            printf("%c",G[p][q]);
            else printf(" ");
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Silver Vortex

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值