PTA 甲级 1027 Colors in Mars(C++)

准大二小白在学技术的同时每天至少一道算法题,以此督促自己,共勉!

1027 Colors in Mars

分数 20

全屏浏览题目

切换布局

作者 CHEN, Yue

单位 浙江大学

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<bits/stdc++.h>
using namespace std;
int n,digit[100],totalNum;
int main(){
    for(int i=0;i<3;i++){
        cin>>n;
        //当原始n不为0时
        if(n!=0){
            if(n>=13){
                digit[totalNum++]=n/13;
                if(n/13<13){
                n=n%13;
                digit[totalNum++]=n;
                continue;
                }
            }
            else {
                // digit[totalNum++]=n%13;
                digit[totalNum++]=0;
                digit[totalNum++]=n%13;
                continue;
            }          
        }
        else if(n==0){
            digit[totalNum++]=0;
            digit[totalNum++]=0;
        }
    }
    cout<<"#";
    for(int i=0;i<totalNum;i++){
        if(digit[i]>=0&&digit[i]<=9)
        cout<<digit[i];
        else if(digit[i]==10){
            cout<<'A';
        }
        else if(digit[i]==11){
            cout<<'B';
        }
        else if(digit[i]==12){
            cout<<'C';
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Silver Vortex

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值