PTA 哈夫曼编码

编写函数实现哈夫曼编码。输入结点个数(保证个数>1)及各结点的权值,为各结点进行编码。

函数接口定义:

CreateHuffman_tree(HuffmanTree &HT,int n);/*建立n个叶子结点的哈夫曼树*/
Huffman_code(HuffmanTree HT,HuffmanCode &HC,int n);//求哈夫曼编码

其中 HT 为哈夫曼树,n 为叶子结点个数, HC 为哈夫曼编码。

裁判测试程序样例:

#include<stdio.h>
#include<string.h>
#include<malloc.h>
typedef struct hnode
{ int weight;
   int lchild,rchild,parent;
 }HTNode,*HuffmanTree;/*定义二叉树的存储结点*/
typedef char **HuffmanCode;
void Select(HTNode HT[],int len,int &s1,int &s2)//选出权值最小的两个结点,下标通过s1和s2传出去
{
    int i,min1=32767,min2=32767;
    for(i=1;i<=len;i++)
    {
        if(HT[i].weight<min1&&HT[i].parent==0)
        {
            s2=s1;
            min2=min1;
            min1=HT[i].weight;
            s1=i;
        }
        else if(HT[i].weight<min2&&HT[i].parent==0)
        {    min2=HT[i].weight;
            s2=i;
        }
    }
}
void CreateHuffman_tree(HuffmanTree &Ht,int n);/*建立哈夫曼树*/
void Huffman_code(HuffmanTree HT,HuffmanCode &HC,int n);/*哈夫曼树编码*/

int main()
{
    HuffmanTree HT;
    HuffmanCode HC;
    int i, n;
    scanf("%d",&n);
    CreateHuffman_tree(HT, n);/*建立哈夫曼树*/
    Huffman_code(HT,HC,n);/*哈夫曼树编码*/
    for(i=1;i<=n;i++)/*输出字符、权值及编码*/
       printf("编码是:%s\n",HC[i]);
    return 0;
}


/* 请在这里填写答案 */

输入样例:

3
1 2 3

输出样例:

编码是:10
编码是:11
编码是:0

 我的代码+注释如下:

void CreateHuffman_tree(HuffmanTree &HT,int n)/*建立n个叶子结点的哈夫曼树*/
{
    int i;
    if(n<=1)return;
    int m=2*n-1;
    HT=new HTNode[m+1];
    for(i=1;i<=m;i++) {HT[i].parent=0;HT[i].lchild=0;HT[i].rchild=0;}
    for(i=1;i<=n;i++) scanf("%d",&HT[i].weight);
    for(i=n+1;i<=m;i++)
    {
        int s1,s2;
        Select(HT,i-1,s1,s2); //从n到1中选择权值最小的两个,返回得到下标s1、s2
        HT[i].lchild=s1;HT[i].rchild=s2;
        HT[i].weight=HT[s1].weight+HT[s2].weight;
        HT[s1].parent=i;HT[s2].parent=i;
        //更新数据
    }
}
void Huffman_code(HuffmanTree HT,HuffmanCode &HC,int n)//求哈夫曼编码
{
    int i,start,c,f;
    HC=new char*[n+1];//开辟n+1个二维字符数组
    char cd[n];
    
    for(i=1;i<=n;i++)
    {
        start=n-1;
        c=i;f=HT[i].parent; //c为当前节点,f为当前节点的父亲节点
        while(f!=0)
        {
            --start;
            if(HT[f].lchild==c) cd[start]='0';
            else cd[start]='1';
            c=f;f=HT[f].parent;  //往上更新节点信息
        }
        HC[i]=new char[n-start];
        strcpy(HC[i],&cd[start]); //传值
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值