hdu 3915 Game

Problem Description
  Mr.Frost is a child who is too simple, sometimes naive, always plays some simple but interesting games with his friends. Today,he invents a new game again:
  At the beginning of the game they pick N (1<=N<=100) piles of stones, Mr.Frost and his friend move the stones in turn. At each step of the game, the player chooses a pile, removes at least one stone from the pile, the first player can’t make a move, and loses. So smart is the friends of Mr.Frost that Mr.Frost always loses. Having been a loser for too many times, he wants to play a trick. His plan is to remove some piles, and then he can find a way to make sure that he would be the winner after his friends remove stones first.

Now, he wants to know how many ways to remove piles which are able to achieve his purpose. If it’s impossible to find any way, please print “-1”.
 

Input
The first line contains a single integer t (1<=t<=20), that indicates the number of test cases. Then follow the t cases. Each test case begins with a line contains an integer N (1 <= N <= 100), representing the number of the piles. The next n lines, each of which has a positive integer Ai(1<=Ai<=2^31 - 1) represent the number of stones in this pile.
 

Output
  For each case, output a line contains the number of the way mod 1000007, If it’s impossible to find any way, please print “-1”.
 

Sample Input
  
  
2 2 1 1 3 1 2 3
 

Sample Output
  
  
2 2
 

Source
 

Recommend
lcy


简单的高斯消元的应用,要求的就是给定n个数中选k个数异或为0的方法数。将n个数用二进制写成n列,之后就很明显了,未知数x1--xn非1即0,表示第i个数取不取。

用高斯消元计算出有多少不确定的变元,这些变元要么是1,要么是0,所以答案即为2的变元数次方。

代码如下

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define maxn 105

int A[105][105];

inline int gauss(int r,int c)
{
    int k,col,i,j,kk;
    int an;
    for(k=col=0;k<r&&col<c;k++,col++)
    {
        kk=k;
        for(i=k+1;i<r;i++)
            if(abs(A[i][col])>abs(A[kk][col])) kk=i;
        if(kk!=k)
        {
            for(j=col;j<=c;j++)
                swap(A[k][j],A[kk][j]);
        }
        if(A[k][col]==0)
        {
            k--;
            continue ;
        }
        for(i=k+1;i<r;i++)
            if(A[i][col]!=0)
                for(j=col;j<=c;j++)
                    A[i][j]^=A[k][j];
    }
    int ans=1;
    for (i=0;i<(c-k);i++)
    {
        ans=(ans*2)%1000007;
    }
    return ans;
}

int main()
{
    int T,i,j,t,up,y,n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        t=0;
        memset(A,0,sizeof(A));
        for (i=0;i<n;i++)
        {
            scanf("%d",&y);
            up=0;
            while(y!=0)
            {
                A[up++][i]=(y & 1);
                y>>=1;
            }
            t=max(t,up);
        }
        for (i=0;i<t;i++)
        {
            A[i][n]=0;
        }
        printf("%d\n",gauss(t,n));
    }
    return 0;
}


内容概要:本文详细介绍了施耐德M580系列PLC的存储结构、系统硬件架构、上电写入程序及CPU冗余特性。在存储结构方面,涵盖拓扑寻址、Device DDT远程寻址以及寄存器寻址三种方式,详细解释了不同类型的寻址方法及其应用场景。系统硬件架构部分,阐述了最小系统的构建要素,包括CPU、机架和模块的选择与配置,并介绍了常见的系统拓扑结构,如简单的机架间拓扑和远程子站以太网菊花链等。上电写入程序环节,说明了通过USB和以太网两种接口进行程序下载的具体步骤,特别是针对初次下载时IP地址的设置方法。最后,CPU冗余部分重点描述了热备功能的实现机制,包括IP通讯地址配置和热备拓扑结构。 适合人群:从事工业自动化领域工作的技术人员,特别是对PLC编程及系统集成有一定了解的工程师。 使用场景及目标:①帮助工程师理解施耐德M580系列PLC的寻址机制,以便更好地进行模块配置和编程;②指导工程师完成最小系统的搭建,优化系统拓扑结构的设计;③提供详细的上电写入程序指南,确保程序下载顺利进行;④解释CPU冗余的实现方式,提高系统的稳定性和可靠性。 其他说明:文中还涉及一些特殊模块的功能介绍,如定时器事件和Modbus串口通讯模块,这些内容有助于用户深入了解M580系列PLC的高级应用。此外,附录部分提供了远程子站和热备冗余系统的实物图片,便于用户直观理解相关概念。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值