Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.
The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:
the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)
The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:
the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)
The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
Sample Input
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
Sample Output
5 2
ps: 这道题求最大独立集,有个公式:最大独立集 = 节点数 - 最大匹配数。但此题有个坑就是男女编号是并没有分开的,也就是说,配对的可能是男男,女女,男女,三种情况。而其中是男女匹配的概率为二分之一,实际最大匹配数 = 所求最大匹配数/2。明白了这点就没什么难度了。
代码:
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
const int MAX=1e3+10;
vector<int> relationship[MAX];
bool vis[MAX];
int partner[MAX];
int k,m,n;
bool find(int female){
for(int i=0;i<relationship[female].size();i++){
int v=relationship[female][i];
if(!vis[v]){
vis[v]=true;
if(partner[v]<0||find(partner[v])){
partner[v]=female;
return true;
}
}
}
return false;
}
int main(){
while(cin>>k){
memset(partner,-1,sizeof(partner));
//memset(relationship,false,sizeof(relationship));
int x,y,z;
for(int i=0;i<k;i++){
scanf("%d: (%d)",&x,&y);
for(int j=0;j<y;j++){
scanf("%d",&z);
relationship[i].push_back(z);
}
}
int ans=0;
for(int i=0;i<k;i++){
memset(vis,false,sizeof(vis));
if(find(i))
ans++;
//
}
for(int i=0;i<k;i++)
relationship[i].clear();
ans/=2;
cout<<k-ans<<endl;
}
return 0;
}
用c++提交一直错,改成g++提交就对了;还是g++好使