HDU - 1796 How many integers can you find

Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
Input
There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
Output
For each case, output the number.
Sample Input
12 2
2 3
Sample Output
7

题意:给出一个集合{}和一个数N,求出元素都小于N的能整除给出集合中的一个数的集合元素的个数

思路:容斥,去重,加标记
AC代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define ll long long
ll a[30];
ll n,m;
ll ans;
int gcd(int a,ll b)
{
    if(b==0)return a;
    else return gcd(b,a%b);
}
void dfs(int p,int f,ll c)
{
    c=a[p]*c/gcd(a[p],c);
    if(f)
    ans+=(n-1)/c;
    else
    ans-=(n-1)/c;
    for(int i=p+1;i<m;i++)
        dfs(i,!f,c);
}
int main()
{
    while(scanf("%lld%lld",&n,&m)!=EOF)
    {
        for(int i=0;i<m;i++)
    {
        scanf("%lld",&a[i]);
    }
    sort(a,a+m);
    ans=0;
    for(int i=0;i<m;i++)
    {
        if(a[i]==0)continue;
        dfs(i,1,a[i]);
    }
    printf("%lld\n",ans);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值