HDU - 4499 Cannon 暴力dfs

In Chinese Chess, there is one kind of powerful chessmen called Cannon. It can move horizontally or vertically along the chess grid. At each move, it can either simply move to another empty cell in the same line without any other chessman along the route or perform an eat action. The eat action, however, is the main concern in this problem.
An eat action, for example, Cannon A eating chessman B, requires two conditions:
1、A and B is in either the same row or the same column in the chess grid.
2、There is exactly one chessman between A and B.
Here comes the problem.
Given an N x M chess grid, with some existing chessmen on it, you need put maximum cannon pieces into the grid, satisfying that any two cannons are not able to eat each other. It is worth nothing that we only account the cannon pieces you put in the grid, and no two pieces shares the same cell.

Input

There are multiple test cases.
In each test case, there are three positive integers N, M and Q (1<= N, M<=5, 0<=Q <= N x M) in the first line, indicating the row number, column number of the grid, and the number of the existing chessmen.
In the second line, there are Q pairs of integers. Each pair of integers X, Y indicates the row index and the column index of the piece. Row indexes are numbered from 0 to N-1, and column indexes are numbered from 0 to M-1. It guarantees no pieces share the same cell.

Output

There is only one line for each test case, containing the maximum number of cannons.

Sample Input

4 4 2 
1 1 1 2 
5 5 8 
0 0 1 0 1 1 2 0 2 3 3 1 3 2 4 0 

Sample Output

8 
9

题目链接:点击查看

题意:有一个n*m的棋盘,原先有q个棋子,问最多能放多少个炮,要求炮不能吃炮

题解:暴力dfs  +  判断即可

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long ll;
int n,m,q;
struct node{
	int x,y;
}p[30];
int mp[6][6],ans;
bool judge(int x,int y)
{
	int flag=0;
	for(int xx=x-1;xx>=0;xx--)
	{
	//	cout<<flag<<" "<<mp[xx][y]<<endl;
		if(flag==1&&mp[xx][y]==2)
		{
	//		cout<<xx<<" "<<y<<endl;
			return 0;
		}
		if(mp[xx][y]) flag++;
		if(flag>2) break;
	}
	flag=0;
	for(int yy=y-1;yy>=0;yy--)
	{
		if(flag==1&&mp[x][yy]==2) return 0;
		if(mp[x][yy]) flag++;
		if(flag>2) break;
	}
	return 1;
}
void dfs(int x,int y,int sum)
{
	
	if(y>=m)
	{
		y=0;
		x++;
	}
//	cout<<x<<" "<<y<<endl;
	if(x>=n)
	{
		ans=max(ans,sum);
		return;
	}
	if(mp[x][y]==1)
	{
		dfs(x,y+1,sum);
	}
	else
	{
		if(judge(x,y))
		{
	//		printf("%d%d\n",x,y);
			mp[x][y]=2;
			dfs(x,y+1,sum+1);
			mp[x][y]=0;
		}
		dfs(x,y+1,sum);
	}
}
int main(){
	int x,y;
	while(~scanf("%d%d%d",&n,&m,&q))
	{
		memset(mp,0,sizeof(mp));
		ans=0;	
		for(int i=1;i<=q;i++)
		{
			scanf("%d%d",&x,&y);
			mp[x][y]=1;
		}
		dfs(0,0,0);
		printf("%d\n",ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值