POJ 1426 Find The Multiple

来自<http://poj.org/problem?id=1426>

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 38108 Accepted: 15916 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source


题意:给你一个数,要求求出一个数是它的倍数,且这个数的十进制形式是由零和一组成

题解:bfs二叉树。答案的范围在longlong内,可以直接bfs

         *poj上要用G++上交

         *bfs的时候不能用while(!q.empty),要用while(1)

#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
#include<queue>
#include<map>
using namespace std;
typedef long long LL;
LL bfs(LL n){
    queue<LL>q;
    q.push(1);
    while(1){
        LL t=q.front();
        q.pop();
        if(t%n==0) return t;
        q.push(t*10);
        q.push(t*10+1);
    }
}
int main(){
    LL n;
    while(scanf("%lld",&n)!=EOF&&n){
        printf("%lld\n",bfs(n));
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值