HDU1695-GCD(数论-欧拉函数-容斥)

GCD

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5454    Accepted Submission(s): 1957


Problem Description
Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
 

Output
For each test case, print the number of choices. Use the format in the example.
 

Sample Input
  
  
2 1 3 1 5 1 1 11014 1 14409 9
 

Sample Output
  
  
Case 1: 9 Case 2: 736427
Hint
For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).
 

题意: 求(1,a) 和(1,b) 两个区间 公约数为k的对数的个数

思路:将a,b分别处以k,就可以转化为(1,a/k)和(1,b/k)两个区间两两互质的个数,可以先用欧拉函数求出(1,a)两两互质的个数,(a+1,b) 可以分解质因数,因为质因数的个数最多为7可以用容斥原理计算。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;

const int maxn = 10000+10;
const int maxxn = 100000+10;
typedef long long ll;
int a,b,gcd;
ll ans;
bool isPrime[maxn];
ll minDiv[maxxn],phi[maxxn],sum[maxxn];
vector<int> prime,cnt[maxxn],digit[maxxn];

void getPrime(){
    prime.clear();
    memset(isPrime,1,sizeof isPrime);
    for(int i = 2;i < maxn; i++){
        if(isPrime[i]){
            prime.push_back(i);
            for(int j = i*i; j < maxn; j+=i){
                isPrime[j] = 0;
            }
        }
    }
}

void getPhi(){
    for(ll i = 1; i < maxxn; i++){
        minDiv[i] = i;
    }
    for(ll i = 2; i*i < maxxn; i++){
        if(minDiv[i]==i){
            for(int j = i*i; j < maxxn; j += i){
                minDiv[j] = i;
            }
        }
    }
    phi[1] = 1;
    sum[1] = 1;
    for(ll i = 2; i < maxxn; i++){
        phi[i] = phi[i/minDiv[i]];
        if((i/minDiv[i])%minDiv[i]==0){
            phi[i] *= minDiv[i];
        }else{
            phi[i] *= minDiv[i]-1;
        }
        sum[i] = phi[i]+sum[i-1];
    }
}

void getDigit(){
    for(ll i = 1; i < maxxn; i++){
        int x = i;
        for(int j = 0; j < prime.size()&&x >= prime[j]; j++){
            if(x%prime[j]==0){
                digit[i].push_back(prime[j]);
                int t = 0;
                while(x%prime[j]==0){
                    t++;
                    x /= prime[j];
                }
                cnt[i].push_back(t);
            }
        }
        if(x!=1){
            digit[i].push_back(x);
            cnt[i].push_back(1);
        }
    }
}

int main(){
    getPrime();
    getPhi();
    getDigit();
    int ncase,T=1;
    cin >> ncase;
    while(ncase--){
        int t1,t2;
        scanf("%d%d%d%d%d",&t1,&a,&t2,&b,&gcd);
        if(gcd==0){
            printf("Case %d: 0\n",T++,ans);
            continue;
        }else{
            if(a > b) swap(a,b);
            a /= gcd,b /= gcd;
            ans = sum[a];
            for(ll i = a+1; i <= b; i++){
                int d = digit[i].size();
                int t = 0;
                vector<int> di;
                for(int k = 1; k < (1<<d); k++){
                    di.clear();
                    for(int f = 0; f < d; f++){
                        if(k&(1<<f)){
                            di.push_back(digit[i][f]);
                        }
                    }
                    int ji = 1;
                    for(int f = 0; f < di.size(); f++){
                        ji *= di[f];
                    }
                    if(di.size()%2==0){
                        t -= a/ji;
                    }else{
                        t += a/ji;
                    }
                }
                ans += a-t;
            }
            printf("Case %d: ",T++);
            cout<<ans<<endl;
        }

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值