HDU 5821 Ball 2016 Multi-University Training Contest 8

Ball

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 662 Accepted Submission(s): 403

Problem Description
ZZX has a sequence of boxes numbered 1,2,…,n. Each box can contain at most one ball.

You are given the initial configuration of the balls. For 1≤i≤n, if the i-th box is empty then a[i]=0, otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.

He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,…,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)

He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.

Input
First line contains an integer t. Then t testcases follow.
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],…,a[n]. Third line contains b[1],b[2],…,b[n]. Each of the next m lines contains two integers l[i],r[i].

1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.

0<=a[i],b[i]<=n.

1<=l[i]<=r[i]<=n.

Output
For each testcase, print “Yes” or “No” in a line.

Sample Input
5
4 1
0 0 1 1
0 1 1 1
1 4
4 1
0 0 1 1
0 0 2 2
1 4
4 2
1 0 0 0
0 0 0 1
1 3
3 4
4 2
1 0 0 0
0 0 0 1
3 4
1 3
5 2
1 1 2 2 0
2 2 1 1 0
1 3
2 4

Sample Output
No
No
Yes
No
Yes

Author
学军中学

Source
2016 Multi-University Training Contest 8

中学生出的乱搞题。。给出两个数列AB,按顺序进行操作。操作定义:提供一个区间,在操作时,可以随意调换区间中数字的顺序。问最后能不能把A换成B。
做法是,首先先记录A中每一个数字最终状态也就是B状态时候的位置(假设能到达这个状态)。当进行一次操作,我们就将要求区间的中的顺序按照刚才记录的顺序进行排队。这样做一遍就结束了。如果最终状态是符合的就是可以,否则就不行。至于原理我觉得其实是一个贪心,你可以发现这个策略一定是最优的,通过分段排序尽量将数字送往其最终所在的位置。

#include "cstring"
#include "cstdio"
#include "iostream"
#include "string.h"
#include "algorithm"
#include "cmath"
using namespace std;
int b[1005];
typedef struct node
{
    int id,num;
}node;
node a[1005];
int vis[1005];
bool cmp(const node &p,const node &q)
{
    return p.id<q.id;
}
int main()
{
    int cas;
    scanf("%d",&cas);
    while(cas--)
    {
        int n,m;
        memset(vis,0,sizeof(vis));
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i].num);
            a[i].id=0;
        }

        for(int i=1;i<=n;i++)
            scanf("%d",&b[i]);
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(a[i].num==b[j]&&vis[j]==0)
                {
                    a[i].id=j;
                    vis[j]=1;
                    break;
                }
            }
        }
        for(int i=1;i<=m;i++)
        {
            int l,r;
            scanf("%d%d",&l,&r);
            sort(a+l,a+1+r,cmp);
        }
        int flag=0;
        for(int i=1;i<=n;i++)
        {
            if(a[i].num!=b[i])
            {
                flag=1;
                break;
            }
        }
        if(flag==0)
            printf("Yes\n");
        else
            printf("No\n");
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值