1015. Reversible Primes (20)
A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.
Sample Input:73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
本题主要是判断给定的数以及其转置是否为素数;
#include <iostream>
#include <vector>
#include <math.h>
using namespace std;
bool isPrime(int n);
int reserve(int n, int d);
int main() {
int n, d;
vector<bool> result;
while (cin>>n)
{
if (n > 0) {
cin >> d;
}
else
break;
if (isPrime(n)) {
n = reserve(n, d);
result.push_back(isPrime(n));
}
else
result.push_back(false);
}
for (int i = 0;i < result.size();i++) {
if (result[i])
cout << "Yes" << endl;
else
cout << "No" << endl;
}
system("pause");
return 0;
}
bool isPrime(int n) {
if (n == 1)
return false;
else if (n == 2 || n == 3)
return true;
else if (n % 2 == 0)
return false;
else {
for (int appr = pow(n, 0.5);appr > 2;appr--) {
if (n%appr == 0)
return false;
}
}
return true;
}
int reserve(int n, int d) {
int did = n;
int mod;
int rev = 0;
while(did>0){
mod = did%d;
rev = rev*d + mod;
did /= d;
}
return rev;
}