[PAT-甲级]1015.Reversible Primes

1015. Reversible Primes (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

解题思路:输入一个数n和d。判断n是不是素数,以及n在d进制下,用d进制表示n这个数的反转过来,再转化成十进制,看这个数是不是素数,如果都是素数则打印YES,否则打印No.

#include<iostream>
using namespace std;

bool isPrime(int num);
int reverseNumber(int num, int radix);

int main()
{
	int n, d;
	while(cin>>n)
	{
		if(n < 0)
			break;
		cin>>d;
		int rev_n = reverseNumber(n, d);
		if(isPrime(n) && isPrime(rev_n))
			cout<<"Yes"<<endl;
		else
			cout<<"No"<<endl;
	}
	return 0;
}

bool isPrime(int num)
{
	if(num < 2)
		return false;
	if(num ==2 || num == 3)
		return true;
	for(int i = 2; i*i <= num; i ++)
		if(num % i == 0)
			return false;
	return true;
}

int reverseNumber(int num, int radix)
{
	int rev_num = 0;
	while(num != 0)
	{
		rev_num *= radix;
		rev_num += num % radix;
		num /= radix;
	}
	return rev_num;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值