Number Sequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 60820 Accepted Submission(s): 13862
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3 1 2 10 0 0 0
Sample Output
2 5
Author
CHEN, Shunbao
Source
Recommend
JGShining
这有个我十分的不解,这个程序整整RE了很多次。可是和我AC的程序只是将len改成i-2
不信你可以试试。
解题思路是找出循环节;
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define N 100000
using namespace std;
int f[N];
int main()
{
f[1]=f[2]=1;
int a,b,n;
int len;
while(cin>>a>>b>>n,a||b||n)
{
int i;
for(i=3;i<10000;i++)
{
f[i]=(a*f[i-1]+b*f[i-2])%7;
if(f[i]==1&&f[i-1]==1)
{
len=i-2;
break;
}
}
n=n%len;
f[0]=f[len];
cout<<f[n]<<endl;
}
return 0;
}
#include<cstring>
#include<iostream>
#include<algorithm>
#define N 100000
using namespace std;
int f[N];
int main()
{
f[1]=f[2]=1;
int a,b,n;
int len;
while(cin>>a>>b>>n,a||b||n)
{
int i;
for(i=3;i<10000;i++)
{
f[i]=(a*f[i-1]+b*f[i-2])%7;
if(f[i]==1&&f[i-1]==1)
{
len=i-2;
break;
}
}
n=n%len;
f[0]=f[len];
cout<<f[n]<<endl;
}
return 0;
}
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define N 100000
using namespace std;
int f[N];
int main()
{
f[1]=f[2]=1;
int a,b,n;
int len;
while(cin>>a>>b>>n,a||b||n)
{
int i;
for(i=3;i<10000;i++)
{
f[i]=(a*f[i-1]+b*f[i-2])%7;
if(f[i]==1&&f[i-1]==1)
{
break;
}
}
n=n%(i-2);
f[0]=f[i-2];
cout<<f[n]<<endl;
}
return 0;
}
#include<cstring>
#include<iostream>
#include<algorithm>
#define N 100000
using namespace std;
int f[N];
int main()
{
f[1]=f[2]=1;
int a,b,n;
int len;
while(cin>>a>>b>>n,a||b||n)
{
int i;
for(i=3;i<10000;i++)
{
f[i]=(a*f[i-1]+b*f[i-2])%7;
if(f[i]==1&&f[i-1]==1)
{
break;
}
}
n=n%(i-2);
f[0]=f[i-2];
cout<<f[n]<<endl;
}
return 0;
}