HDU 2586(LCA)

How far away ?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23069    Accepted Submission(s): 9129


 

Problem Description

There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.

 

 

Input

First line is a single integer T(T<=10), indicating the number of test cases.
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.

 

 

Output

For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.

 

 

Sample Input

 

2 3 2 1 2 10 3 1 15 1 2 2 3 2 2 1 2 100 1 2 2 1

 

 

Sample Output

 

10 25 100 100

 

 

LCA 裸题啊      直接贴代码

 

 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct point {
    int to,next,v;
};
point a[40005*2];
int cnt,h[40005];
void add(int x,int y,int z) {
    a[++cnt].next=h[x];
    a[cnt].to=y;
    a[cnt].v=z;
    h[x]=cnt;
}
int high[40005],hi[40005],f[40005][17];
void build(int u,int father,int w) {
    f[u][0]=father;
    for(int i=1; i<=16; i++)f[u][i]=f[f[u][i-1]][i-1];
    high[u]=high[father]+w;
    hi[u]=hi[father]+1;
    for(int i=h[u]; i; i=a[i].next) {
        int v=a[i].to;
        if(v==father)continue;
        build(v,u,a[i].v);
    }
}
int lcy(int x,int y) {
    if(hi[x]<hi[y])swap(x,y);
    for(int i=16; i>=0; i--)if(hi[f[x][i]]>=hi[y])x=f[x][i];
    if(x==y)return x;
    for(int i=16; i>=0; i--)if(f[x][i]!=f[y][i]) {
            x=f[x][i];
            y=f[y][i];
        }
    return f[x][0];
}
int main() {
    int t;
    cin>>t;
    for(int i=1; i<=t; i++) {
        memset(h,0,sizeof(h));
        memset(high,0,sizeof(high));
        memset(hi,0,sizeof(hi));
        memset(f,0,sizeof(f));
        cnt=0;
        int n,m,x,y,z;
        cin>>n>>m;
        for(int i=1; i<n; i++) {
            scanf("%d%d%d",&x,&y,&z);
            add(x,y,z);
            add(y,x,z);
        }
        hi[1]=1;
        build(1,0,0);
        for(int i=1; i<=m; i++) {
            scanf("%d%d",&x,&y);
            printf("%d\n",high[x]+high[y]-2*high[lcy(x,y)]);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值