Dancing Stars on Me
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 583 Accepted Submission(s): 309
Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.
Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
Input
The first line contains a integer
T
indicating the total number of test cases. Each test case begins with an integer
n
, denoting the number of stars in the sky. Following
n
lines, each contains
2
integers
xi,yi
, describe the coordinates of
n
stars.
1≤T≤300
3≤n≤100
−10000≤xi,yi≤10000
All coordinates are distinct.
1≤T≤300
3≤n≤100
−10000≤xi,yi≤10000
All coordinates are distinct.
Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
Sample Input
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
Sample Output
NO YES NO
找出每个点离其他点的距离,然后排序,如果这些点能构成正多边形,那么最短的两条距离应该相等,而且要全部相等,才能构成一个正多边形!但是只要有一个不想等,就不能构成!
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
double so(double x1,double y1,double x2,double y2)
{
return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
int main()
{
double a,b,c,d,x[110],y[110],dis[1100];
int i,j,m,n,flag;
scanf("%d",&m);
while(m--)
{
flag=0;
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%lf%lf",&x[i],&y[i]);
for(i=0;i<n;i++)
{
int t=0;
for(j=0;j<n;j++)
{
if(j!=i)
dis[t++]=so(x[i],y[i],x[j],y[j]);
}
sort(dis,dis+t);
if(dis[0]!=dis[1])
flag=1;
}
if(flag)
printf("NO\n");
else
printf("YES\n");
}
return 0;
}