POJ 1094 Sorting It All Out(拓扑排序)

Sorting It All Out
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 32789 Accepted: 11387

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

Source

题目大意:n表示字母的个数,m表示有m个关系,输出有三种情况,1:在输入x个关系后出现环,2:在输入y个关系后出现关系唯一的一个排列,3:输入完毕后仍然不能queding序列关系。判断的先后顺序要按照1,2,3来判断,如果出现前两种情况,那么对后面输入不再进行任何操作。

int toposort()
{
    while(!q.empty())q.pop();
    int flag=1;
    for(int i=1; i<=n; i++)
        d[i]=du[i];
    memset(vis,0,sizeof(vis));
    for(int i=1; i<=n; i++)
    {
        int s=0;
        int x;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&!d[j])
            {
                s++;
                x=j;
            }
        }
        printf("%d",s);
          if(s>1)flag=-1;//序列不唯一<span style="color:#ff0000;">//这里如果直接return -1,将会出后面会出现环的情况被忽略,eg:s=  3,2,1,0,0,.....</span>
                                                       
        if(s==0)  return 0;//有环
        vis[x]=1;
        char c=x-1+'A';
        q.push(c);
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&mp[x][j])d[j]--;
        }
    }
    return flag;
}

#include<stdio.h>
#include<string.h>
#include<queue>

using namespace std;

int vis[30];
int mp[30][30];
int du[30];
int v[30];
int d[30];
int n;
queue<char>q;
int toposort()
{
    while(!q.empty())q.pop();
    int flag=1;
    for(int i=1; i<=n; i++)
        d[i]=du[i];
    memset(vis,0,sizeof(vis));
    for(int i=1; i<=n; i++)
    {
        int s=0;
        int x;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&!d[j])
            {
                s++;
                x=j;
            }
        }
        printf("%d",s);
          if(s>1)flag=-1;//序列不唯一
        if(s==0)  return 0;//有环
        vis[x]=1;
        char c=x-1+'A';
        q.push(c);
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&mp[x][j])d[j]--;
        }
    }
    return flag;
}
int main()
{
    int m;
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)break;
        memset(mp,0,sizeof(mp));
        memset(du,0,sizeof(du));
        int t=0;
        int xx;
        int tt=0;
        int yy;
        for(int  i=1; i<=m ; i++)
        {
            char a[5];
            scanf("%s",a);
            if(!t&&!tt)
            {
                int x=a[0]-'A'+1;
                int y=a[2]-'A'+1;
                if(!mp[x][y])
                {
                    mp[x][y]=1;
                    du[y]++;
                }
                int ss=toposort();
                printf("----%d %d\n",i,ss);
                if(ss==0)//有环
                {
                    t=1;
                    xx=i;
                    if(t)printf("Inconsistency found after %d relations.\n",xx);
                }
                if(ss==1)//有序
                {
                    tt=1;
                    yy=i;
                    if(tt)
                    {
                        printf("Sorted sequence determined after %d relations: ",yy);
                        while(!q.empty())
                        {
                            printf("%c",q.front());
                            q.pop();
                        }
                        printf(".\n");
                    }
                }
            }
        }
        if(!t&&!tt)  printf("Sorted sequence cannot be determined.\n");
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值