区间dp入门:poj 3280 Cheapest Palindrome poj 2955 Brackets

poj 3280 Cheapest Palindrome

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers:  N and  M 
Line 2: This line contains exactly  M characters which constitute the initial ID string 
Lines 3..  N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

题意: 输入n,m,m为下面要输入的字符串的长度,n为字符串中的不同字符个数,下面一行为字符串,紧接着有n行,格式为 c x y ;c 为一个字符,x为 添加这个字符的花费,y为删除这个字符的花费,输出:把整个字符串经过删除和添加字符变成回文字符串的最小花费;

思路: 我刚开始这道题之前,没有接触过区间dp,无从下手,这道题其实就是一个区间dp 的入门题;

dp[i][j]  表示 i~j 之间的变成回文序列的所需的最小花费;

这道题只需注意  区间的最前端和最后端  就行了,下面那道题就不是了;

如果 str[i]==str[j], dp[i][j] = dp[i+1][j-1];

如果 dp[i+1][j] 为 回文序列,dp[i][j]  = dp[i+1][j] + min(add(str[i]) , delt(str[i]));

如果 dp[i][j-1] 为回文序列,dp[i][j] = min(dp[i][j]  ,  dp[i][j+1] + min(add(str[j],delt(str[i])) ));

代码区间dp的模板:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define Max 2200
int cost[30];
int dp[Max][Max]; // dp[i][j] 存从i到j 这个区间内的字符串经过增或删 形成回文字符串的最少费用; 
int main()
{
	int n,m;
	int i,j;
	char str[Max];
	while(~scanf("%d%d",&n,&m))
	{
		scanf("%s",str);
		char c;
		int x,y;
		for(i = 0;i<n;i++)
		{
			getchar();
			scanf("%c %d %d",&c,&x,&y);
			cost[c-'a'] = min(x,y);  // 因为是回文序列,虽说添加和删除组成的字符串不一样;
									// 但是 最终形成的都是回文字符串; 
		}
		// 区间dp的模板;  // 自己模拟一边; 
		memset(dp,0,sizeof(dp));
		for(int len = 1; len < m; len++)
		{
			for(i = 0,j = len; j<m; i++,j++)
			{
				if(str[i]==str[j])  dp[i][j] = dp[i+1][j-1];
				else
				{
					dp[i][j] = dp[i][j-1] + cost[str[j]-'a'];
					dp[i][j] = min(dp[i][j],dp[i+1][j] + cost[str[i]-'a']); 
				}
			}
		} 
		printf("%d\n",dp[0][m-1]);
	}
	return 0;
} 

(0,1)(1,2)(2,3)

      (0,2)  (1,3)

            (0,3) 

自己模拟一边,体会一下;

poj 2955  Brackets

题目链接:点击打开链接

 题意:给一个括号序列,问你其中子序列中最长合法的子序列长度(我感觉是长度,当时为什么有的博客说是匹配的对数),若A合法,则[A],(A)均合法,若A,B合法则AB也合法

这道题不但要注意外围最前端和最后端,还有注意中间分割点;

1)外围匹配:dp[i][j] = dp[i + 1][j - 1]+2;

2)枚举分割点:dp[i][j] = min(dp[i][j], dp[i][k] + dp[k + 1][j]); (i <= k < j)

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#include<map>

map<char,char> m;
#define Max 110
char str[Max];
int dp[Max][Max];


void init()
{
	m['['] = ']';
	m['('] = ')';
	m[']'] = '0';
	m[')'] = '1';
}
int main()
{
	init();
	while(~scanf("%s",str))
	{
		if(strcmp(str,"end")==0)
			break;
		int l = strlen(str);
		int i,j;
		
		memset(dp,0,sizeof(dp));
		for(int len = 1; len<l; len ++)
		{
			for( i = 0,j = len;j<l;i++,j++)
			{
				
				if(m[str[i]] == str[j])
					dp[i][j] = dp[i+1][j-1]+2;
				for(int k = i; k<j; k++)    // 分割点,要从i开始,不要从i+1开始 
				{							// 给出一组数据 ][][,就知道为啥了; 
					dp[i][j] = max(dp[i][j],dp[i][k] + dp[k+1][j]);
				}
			}
		}
		printf("%d\n",dp[0][l-1]);
	}
	return 0;
} 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值