hdu 5904 LCIS

Problem Description
Alex has two sequences a1,a2,…,an and b1,b2,…,bm. He wants find a longest common subsequence that consists of consecutive values in increasing order.

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains two integers n and m (1≤n,m≤100000) – the length of two sequences. The second line contains n integers: a1,a2,…,an (1≤ai≤106). The third line contains n integers: b1,b2,…,bm (1≤bi≤106).

There are at most 1000 test cases and the sum of n and m does not exceed 2×106.

Output
For each test case, output the length of longest common subsequence that consists of consecutive values in increasing order.

Sample Input

3
3 3
1 2 3
3 2 1
10 5
1 23 2 32 4 3 4 5 6 1
1 2 3 4 5
1 1
2
1

Sample Output

1
5
0

题解:

   我们先预处理出a,b数组中以每个数为结尾的最长连续递增子序列长度,由于题目要求连续递增的。所以可得ca[i]=ca[i-1]+1; 之后min(a[i],b[i])最小值的最大值即可

代码:

#include <bits/stdc++.h>

using namespace std;
const int maxn=100000+10;
typedef long long LL;
LL a[maxn],b[maxn];
LL n,m;
LL ca[maxn],cb[maxn];
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        cin>>n>>m;
        memset(ca, 0, sizeof ca);
        memset(cb, 0, sizeof cb);
        for(int i=0;i<n;i++)
           {
               scanf("%d", &a[i]);
               ca[a[i]] = ca[a[i]-1]+1;
           }
        for(int i=0;i<m;i++)
            {
                scanf("%d", &b[i]);
                cb[b[i]] = cb[b[i]-1]+1;
            }
        LL ans=0;
        for(int i=1;i<=maxn;i++)
        {
            ans=max(ans,min(ca[i],cb[i]));
        }
        printf("%d\n", ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值