HDU 2141 Can you find it?二分

Can you find it?
Time Limit:3000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X. 
 

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers. 
 

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO". 
 

Sample Input

      
      
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output

      
      
Case 1: NO YES NO
 

即给出一个A数组,B数组,C数组,和S个询问,每个询问给出一个X值,问是否存在符合条件的等式。

分析:可以用a1存下a数组和b数组中所有元素的和,然后可以用二分的方法查找是否存在x-c[i]即可。

将两数组组合,防超时

#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
int a[1010],b[1010],c[1010],a1[1000000];
int main()
{
	int n,m,l,x,k=1,h,w;
	while(~scanf("%d%d%d",&l,&n,&m))
	{w=0;
		for(int i=0;i<l;i++)
		scanf("%d",&a[i]);
			for(int i=0;i<l;i++)
		scanf("%d",&b[i]);
			for(int i=0;i<l;i++)
		scanf("%d",&c[i]);
		for(int i=0;i<l;i++)
		for(int j=0;j<n;j++)
		a1[w++]=a[i]+b[j];//重组数组
		sort(a1,a1+w);//排序
		scanf("%d",&h);
		printf("Case %d:\n",k++);
		int p;
		for(int i=0;i<h;i++)
		{scanf("%d",&x);
		p=0;
		for(int i=0;i<m;i++)
		{int t=x-c[i];
		  int left,right,mid;
       left=0;
      right=w-1;
      mid=(left+right)/2;
      while(left<=right)//二分
      {
        mid=(left+right)/2;
        if(a1[mid]==t)
          {p=1;
          break;
          }
        else if(a1[mid]>t)
          right=mid-1;
        else if(a1[mid]<t)
          left=mid+1;
    }
	if(p==1)
	{
	break;
	}
				
		
		}
		if(p==1)
		printf("YES\n");
		else
		printf("NO\n");	
		}
		
		
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值