hdu 2647 Reward(拓扑排序)

Reward
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards. 
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000) 
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.

Output

For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.

Sample Input

2 1
1 2
2 2
1 2
2 1

Sample Output

1777
-1
 #include<queue>
 #include<cstdio>
 #include<cstring>
 #include<iostream>
 #include<algorithm>
 using namespace std; 
 const int M = 1e4 + 10;
 int head[M],into[M],n,m,cas,money[M];
 struct Edge{
     int to;  
     int next;
 }edge[M*2];
  void init()
 {
     for (int i=1 ; i<=n ; i++){
         head[i]=-1;
         into[i]=0;
         money[i]=888;//所有人低价为888
     }
 } 
 void addedge(int u,int v)//链表关系,从小到大
 {
    edge[cas].to=v;  
     edge[cas].next=head[u]; 
     head[u]=cas++;  
     into[v]++; 
 } 
 int topu()
 {
     queue<int>que;//队列
     int num=0,sum=0;
     for (int i=1 ; i<=n ; i++)
         if (into[i]==0)
             que.push(i);
     while (!que.empty()){
         int u=que.front();
         sum+=money[u];
         que.pop();
         num++;
         for (int i=head[u] ; i!=-1 ; i=edge[i].next){
             into[edge[i].to]--;
             if (into[edge[i].to]==0){
                 que.push(edge[i].to);
                 money[edge[i].to]=money[u]+1;
             }
        }
    }
     if (num!=n) return -1;//判断是否存在环
     return sum;
 }
 
int main()
 {
     while (~scanf("%d%d",&n,&m)){
         init();
         cas=0;
         while (m--){
             int a,b;
             scanf("%d%d",&a,&b);
             addedge(b,a);//a的工钱比b大,所以反向填入;
         }
         printf("%d\n",topu());
     }
     return 0;
 }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值