HDOJ 5610 Baby Ming and Weight lifting(枚举)



Baby Ming and Weight lifting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 68    Accepted Submission(s): 32


Problem Description
Baby Ming is fond of weight lifting. He has a barbell pole(the weight of which can be ignored) and two different kinds of barbell disks(the weight of which are respectively a and b ), the amount of each one being infinite.

Baby Ming prepare to use this two kinds of barbell disks to make up a new one weighted
C (the barbell must be balanced), he want to know how to do it.

 

Input
In the first line contains a single positive integer T , indicating number of test case.

For each test case:

There are three positive integer
a,b , and C .

1T1000,0<a,b,C1000,ab
 

Output
For each test case, if the barbell weighted C can’t be made up, print Impossible.

Otherwise, print two numbers to indicating the numbers of
a and b barbell disks are needed. (If there are more than one answer, print the answer with minimum a+b )
 

Sample Input
  
  
2 1 2 6 1 4 5
 

Sample Output
  
  
2 2 Impossible
 

题意:有两个杠铃片,重量分别为a,b。要想使杠铃总重量为C,需要a,b的个数分别为多少?要求输出的num_a,num_b使得num_a+num_b最小。

题解:杠铃左右两边重量相等的,只考虑一边就可以了,枚举使得num_a*a+num_b*b=C/2的最小的num_a,num_b。最后输出记得乘以2就行了。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
#define INF 0x3f3f3f

int main()
{
	int t,a,b,C;
	int n,cnt_a,cnt_b,i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d%d",&a,&b,&C);
		cnt_a=INF; cnt_b=INF;
			for(i=0;;++i)
			{
				for(j=0;;++j)
				{
					if((a*i+b*j)*2>C)
						break;
					if((a*i+b*j)*2==C)
					{
						if(i+j<cnt_a+cnt_b)
						{
							cnt_a=i;
							cnt_b=j;
						}
					}
				}
				if(a*i>C)
					break;
			}
		if(cnt_a==INF&&cnt_b==INF)
			printf("Impossible\n");
		else
			printf("%d %d\n",cnt_a*2,cnt_b*2);
	}
	return 0;
} 






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值