poj 2528 线段树离散化+区间更新

Mayor's posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40456 Accepted: 11766

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

Source

题意:在墙上贴海报,海报可以互相覆盖,问最后可以看见几张海报

思路:这题数据范围很大,直接搞超时+超内存,需要离散化:

离散化简单的来说就是只取我们需要的值来用,比如说区间[1000,2000],[1990,2012] 我们用不到[-,999][1001,1989][1991,1999][2001,2011][2013,+]这些值,所以我只需要1000,1990,2000,2012就够了,将其分别映射到0,1,2,3,在于复杂度就大大的降下来了

所以离散化要保存所有需要用到的值,排序后,分别映射到1~n,这样复杂度就会小很多很多

而这题的难点在于每个数字其实表示的是一个单位长度(并非一个点),这样普通的离散化会造成许多错误(包括我以前的代码,poj这题数据奇弱)

给出下面两个简单的例子应该能体现普通离散化的缺陷:

例子一:1-10 1-4 5-10

例子二:1-10 1-4 6-10

普通离散化后都变成了[1,4][1,2][3,4]

线段2覆盖了[1,2],线段3覆盖了[3,4],那么线段1是否被完全覆盖掉了呢?

例子一是完全被覆盖掉了,而例子二没有被覆盖

 

为了解决这种缺陷,我们可以在排序后的数组上加些处理,比如说[1,2,6,10]

如果相邻数字间距大于1的话,在其中加上任意一个数字,比如加成[1,2,3,6,7,10],然后再做线段树就好了.

线段树功能:update:成段替换 query:简单hash

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 40005
struct node
{
    int x,y,p;
}a[N*4];
int sum,b[N],c[N],mark[N],l[N],r[N];
int binary(int k,int l,int r)
{
    while(l<=r)
    {
        int mid=(l+r)>>1;
        if(c[mid]==k)  return mid;
        else if(c[mid]>k)
            r=mid-1;
        else
            l=mid+1;
    }
    return l;
}
void build(int t,int x,int y)
{
    a[t].x=x;
    a[t].y=y;
    a[t].p=0;
    if(x==y)  return;
    int mid=(x+y)>>1,temp=t<<1;
    build(temp,x,mid);
    build(temp+1,mid+1,y);
}
void update(int t,int x,int y,int c)
{
    if(a[t].x==x&&a[t].y==y)
    {
        a[t].p=c;
        return;
    }
    int mid=(a[t].x+a[t].y)>>1,temp=t<<1;
    if(a[t].p)
    {
        a[temp].p=a[temp+1].p=a[t].p;
        a[t].p=0;
    }
    if(y<=mid)
        update(temp,x,y,c);
    else if(x>mid)
        update(temp+1,x,y,c);
    else
    {
        update(temp,x,mid,c);
        update(temp+1,mid+1,y,c);
    }
}
void query(int t)
{
    if(a[t].p)
    {
        if(mark[a[t].p]==0)
        {
            mark[a[t].p]=1;
            sum++;
        }
        return ;
    }
    if(a[t].x==a[t].y)  return; //所有的区间都没有覆盖当前的结点,直接返回
    int temp=t<<1;
    query(temp);
    query(temp+1);
}
int main()
{
    int t,m,k,i,num,x,y;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&m);  k=1;
        for(i=1;i<=m;i++)//存点
        {
          scanf("%d%d",&l[i],&r[i]);
            b[k++]=l[i];
            b[k++]=r[i];
        }
        sort(b+1,b+k);
        num=1;  c[1]=b[1];
        for(i=2;i<k;i++)//去重点
        {
            if(b[i]!=b[i-1])
               c[++num]=b[i];
        }
        for(i=num;i>=2;i--)//加点
        {
            if(c[i]>c[i-1]+1)
                c[++num]=c[i-1]+1;
        }
        sort(c+1,c+num+1);
        build(1,1,num);
        for(i=1;i<=m;i++)
        {
            x=binary(l[i],1,num);//寻找位置
            y=binary(r[i],1,num);
            //printf("%d %d\n",x,y);
            update(1,x,y,i);//更新区间
        }
        memset(mark,0,sizeof(mark));
        sum=0;
        query(1);//查询
        printf("%d\n",sum);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值