hdu 2680 Choose the best route (dijkstra算法 最短路问题)

题目链接:h ttp://acm.hdu.edu.cn/showproblem.php?pid=2680

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7201    Accepted Submission(s): 2350


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

 

Sample Input
5 8 51 2 21 5 31 3 42 4 72 5 62 3 53 5 14 5 122 34 3 41 2 31 3 42 3 211
 

 

Sample Output
1-1
 
 
题目大意:这个题目的变量比较多,所以比较恶心啦。不过也就是dijkstra的模板问题~
也是给了起点和终点然后找出最短路。这里有一个小技巧就是虚拟起点为"0",把0到任一个真正的起点的距离置为0,到其他点为无穷大,这样可以节省很多时间!!
还有一个要注意的就是这个路是单向的,今天刚过了英语四级,看着英文题目觉得还可以了哈~(*^__^*) 嘻嘻……
 
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int node[1010],map[1010][1010],n,Min;
const int INF=9999999;

void dijkstra()
{
    int vis[1010]= {0};
    int tm=0,m;
    node[tm]=0;
    vis[tm]=1;
    for(int i = 1; i <= n; i++)
        node[i] = INF;
    for (int k=2; k<=n; k++)
    {
        Min=INF;
        for (int i=1; i<=n; i++)
            if (!vis[i])
            {
                if (node[i]>map[tm][i]+node[tm])
                    node[i]=map[tm][i]+node[tm];
                if (Min>node[i])
                {
                    Min=node[i];
                    m=i;
                }
            }
        vis[m]=1;
        tm=m;
    }
}

int main ()
{
    int m,s;
    while (~scanf("%d%d%d",&n,&m,&s))
    {
        memset(map, INF, sizeof(map));
        for (int i=1; i<=m; i++)
        {
            int p,q,t;
            cin>>p>>q>>t;
            if (map[p][q]>t)
                map[p][q]=t;
        }
        int w,cost;
        cin>>w;
        for (int i=1; i<=w; i++)
        {
            scanf ("%d",&cost);
            map[0][cost]=0;
        }
        dijkstra();
        if(node[s] ==INF)
            printf("-1\n");
        else
            printf("%d\n", node[s]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值