HDU 2588 GCD (欧拉函数)

GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1013    Accepted Submission(s): 457



Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
 

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
 

Output
For each test case,output the answer on a single line.
 

Sample Input
  
  
3 1 1 10 2 10000 72
 

Sample Output
  
  
1 6 260
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1695  1787  3501  2824  2582

模板题目,新手对数论理解有限,求指导。

题意:

分析:假设x<=n,n=p*d,x=q*d.假设n与x的最大公约数为d,则能够推出p与q肯定是互质的,因为x<=n所以要求的就是p的欧拉函数值了,那么我们就转化成求满足:n=p*d,并且d>=m的p的欧拉函数值之和了。

代码实现:

#include <cstring>
#include <cstdio>
int OL(int n)   //大白书上的求一个数的欧拉函数模板。
{
    int res=n,i,j;
    for(i=2;i*i<=n;i++)
    {
        if(n%i==0)
        {
           // n/=i;
            while(!(n%i)) n/=i;
            res=res/i*(i-1);
        }
    }
    if(n!=1) res=res/n*(n-1);
return res;
}
int main()
{
    int n,i,j,m,sum,T;
    while(scanf("%d",&T)!=EOF)
    {
        while(T--)
        {
            sum=0;
            scanf("%d%d",&n,&m);
            for(i=1;i*i<=n;i++)
            if(n%i==0)
            {
                if(i>=m)
                sum+=OL(n/i);
                if((n/i)!=i && (n/i)>=m)
                sum+=OL(i);
            }
         printf("%d\n",sum);
        }
    }
    return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值