POJ 1426 Find The Mutiple

Find The Mutiple
  Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22958 Accepted: 9457 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100

111111111111111111



刚看到这题的时候被它的数据量给吓到了,总想着它DFS肯定会超时,而BFS肯定会超空间。后来发现这个题没有那么难,用一个初始值为1的数m。进行深搜或广搜(m*10;m*10+1),一步步进行操作就可以了。这个我是一次过的,至于网上有的博客说会超空间什么的我觉得不会,直接用long long 来存这个数就足够了,不需要开辟很大的数组进行广搜。至于深搜,对于步骤数要进行控制,即不能操作超过19次,否则会出错。嗯嗯,网上还有很好的剪枝方案,值得去看下。


DFS:
#include <iostream>
#include <cstdio>
using namespace std;
int flag,n;
void dfs(long long int m,int step)
{
    if(flag||step==19)
        return;
    if(m%n==0)
    {
        printf("%lld\n",m);
        flag=1;
        return;
    }
    dfs(m*10,step+1);
    dfs(m*10+1,step+1);
    return;
}
int main()
{
    while(scanf("%d",&n)&&n)
    {
        flag=0;
        dfs(1,0);
    }
    return 0;
}
BFS:
#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;
int n;
void bfs()
{
    queue<long long int> Q;
    long long int m=1;
    Q.push(m);
    while(!Q.empty())
    {
        m=Q.front();
        Q.pop();
        if(m%n==0)
        {
            printf("%lld\n",m);
            return;
        }
        Q.push(m*10);
        Q.push(m*10+1);
    }
}
int main()
{
    while(scanf("%d",&n)&&n)
    {
        bfs();
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值