HDU 1098 Ignatius's puzzle

12 篇文章 0 订阅

/*
中文题意:给你一个 k  让你求出最小的a
中文翻译:输入一个整数k(k<10000),找出最小的整数a,使得对于任意的x ,带入方程中都能被65整除。
题目大意:给定f(x)=5*x^13+13*x^5+k*a*x,现给出k值 ,求能使x取任意值都能使f(x)%65==0的最小a值。
解题思路:数论,

数学归纳法,使f(0)能整除65 然后 假设 f(x)能整除65 证明f(x+1)也能整除65,这样就能满足题意任意x的条件了。
f(0)=0 能整除65, f(1)=18+ka 能整除65(假设的),假设f(x)能整除65,那么f(x+1)=f(x)+5*[C(13,1)x^12+……+C(13,13)x^0]+13*[C(5,1)x^4……+C(5,5)x^0]+ka=f(x)+5*[C(13,1)x^12+……+C(13,12)x^1]+13*[C(5,1)x^4……+C(5,4)x^1]+18+ka。(二项式展开,泰勒展开)
可以发现除了18+ka外 其他都能整除65;所以要使f(x+1)要能整除65,那么需要18+ka要能整除65(注意
:这不是个充要条件 ,而是一个必要不充分条件)
现在整个问题转换为  使 18+ka 能整除65的最小 a值;假设k=1,而要使a值最小 那么a最大能取到65
所以直接枚举每个样例a到65即
难点详解:65|f(x)的意思是f(x)能被65整除,个人感觉可以投机取巧一下,既然是对任意的x,所以就取一和零两个数就快速写出来了
关键点:看懂题意,是对与任意的x满足题意
解题人:lingnichong
解题时间:2014/08/08   16:48
解题感受:数学不好,只能投机取巧一点了。
*/



Ignatius's puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6295    Accepted Submission(s): 4347


Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

 

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
 

Output
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
 

Sample Input
  
  
11 100 9999
 

Sample Output
  
  
22 no 43
 


#include<stdio.h>
int main()
{
	int k,i,a;
	while(~scanf("%d",&k))
	{
		a=0;
		for(i = 0; i <= 65; i++)
		{
			if((18+k*i)%65==0)
			{
				a=i;
				break;
			}
		}
		if(a!=0)
			printf("%d\n", a);
		else
			printf("no\n");
	}
	
	return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值