PAT 1009. Product of Polynomials (25)(多项式乘法)(待修改)

题目

1009. Product of Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6

解题思路

  • 1.由于每行的输入都是由高次到低次,并且不重复的,所以可以写的更简单,还要考虑浮点数问题,但是我感觉都考虑到了,第一个测试点还是通不过!!!不知道错在哪!
  • 2.又想了下,难道是有个指数的和项大于1.e*10 -8,但是每一项不大于?测试点这么叼?

代码(测试一通不过)

#include<iostream>
#include<iomanip>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
int exp1[1001];double coe1[1001];
map<int ,double > product;
bool cmp(int a,int b){
    return a>b;
}
const double eps = 1.e-8;
int main(int argc, char *argv[])
{
    ios_base::sync_with_stdio(false);
    //输入第一组数据
    int n1;
    cin >> n1;
    for (int i = 0; i < n1; ++i) {
        cin >> exp1[i] >> coe1[i];
    }
    //输入第二组数据并计算乘积
    int n2;
    cin >> n2;
    int exp2,exp3;double coe2,coe3;
    vector<int> keep;
    for (int i = 0; i < n2; ++i) {
        cin >> exp2 >> coe2;
        for (int i = 0; i < n1; ++i) {
            exp3 = exp2 + exp1[i];
            coe3 = coe2 * coe1[i];
            if (coe3 > eps) {
                if (product[exp3] ==0) {
                   product[exp3] = coe3;
                   keep.push_back(exp3);
                }else {
                    product[exp3] += coe3;
                }
            }
        }
    }
    if (!keep.empty()) {
        sort(keep.begin(),keep.end(),cmp);
    }
    cout << keep.size();
    for (int i = 0; i < keep.size(); ++i) {
        cout << " " << keep[i] << " " << fixed << setprecision(1) << product[keep[i]];
    }
    cout << endl;
    return 0;
}

AC代码

#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>

using namespace std;

const double eps = 1.e-8;

double a[1024],b[1024],c[2048];

int main() {
int n;
    for (scanf("%d",&n);n;--n) {
        int x;
        scanf("%d",&x);
        scanf("%lf",a + x);
    }
    for (scanf("%d",&n);n;--n) {
        int x;
            scanf("%d",&x);
            scanf("%lf",b + x);
        }
    for (int i = 0; i <= 1000; ++i) {
        for (int j = 0; j <= 1000; ++j) {
            c[i + j] += a[i] * b[j];
        }
    }
    int num = 0;
    for (int i = 2000; i >= 0; --i) {
        if (fabs(c[i]) >= eps) {
            ++num;
        }
    }
    printf("%d",num);
    for (int i = 2000; i >= 0; --i) {
        if (fabs(c[i]) >= eps) {
            printf(" %d %.1lf",i,c[i]);
        }
    }
    puts("");
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值