poj 1860-Currency Exchange(Bellman_Ford算法)

39 篇文章 0 订阅

传送门

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES


解法:

Bellman-Ford算法可以找出图G是否存在一个负权值回路,本题需要找出一个正权值回路,即经过一系列兑换后货币总额是增加的。

所谓正权回路就是从源点s出发的一条回路上,顶点的权值能不断增加,即边可以一直进行松弛操作。

建模:每一种货币是图G中的一个顶点,每一个兑换点是针对该兑换点的两种货币的兑换规则,即相当于两个顶点的两条边(正向和反向),本题即要求找出一条能无限松弛的最大正权路径。

初始化dis[s]=v,源点到其他点的权值为0,当s点到其它某点的距离能不断变大时,说明存在最大正权路径;

松弛条件:if(dis[edge[j].v] < (dis[edge[j].u] - edge[j].c)*edge[j].r)

即如果将当前货币a兑换成b后,比b处的值要大的话就进行兑换(松弛),经过(|N|-1)次每一条边的松弛后,每个顶点都是该种货币的最大兑换值,最后每条边再进行一次松弛,看是否能构成正权回路。

代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <algorithm>
const long long N = 100+10,M = 210, MAX = 100000;
using namespace std;
struct Edge
{
    int u, vv;
    double r, c;
}edge[M];
int n, m, s, cnt;
double v, dis[N];
bool Bellman_Ford()
{
    memset(dis, 0, sizeof(dis));
    dis[s] = v;
    for (int i = 1; i < n; i++)
    {
        for (int j = 0; j < cnt; j++)
        {
            if (dis[edge[j].vv] < (dis[edge[j].u]-edge[j].c)*edge[j].r)
            {
                dis[edge[j].vv] = (dis[edge[j].u]-edge[j].c)*edge[j].r;
            }
        }
    }
    for (int i = 0; i < cnt; i++)
    {
        if (dis[edge[i].vv] < (dis[edge[i].u]-edge[i].c)*edge[i].r)
        {
            return true;
        }
    }
    return false;
}
int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    int i, j, u, vv;
    double c1, r1, c2, r2;
    while(cin >> n >> m >> s >> v)
    {
        cnt = 0;
        for (i = 0; i < m; i++)
        {
            cin >> u >> vv >> r1 >> c1 >> r2 >> c2;
            edge[cnt].u = u;
            edge[cnt].vv = vv;
            edge[cnt].r = r1;
            edge[cnt].c = c1;
            cnt++;
            edge[cnt].u = vv;
            edge[cnt].vv = u;
            edge[cnt].r = r2;
            edge[cnt].c = c2;
            cnt++;
        }
        if (Bellman_Ford())
        {
            cout << "YES" << endl;
        }
        else
        {
            cout << "NO" << endl;
        }
    } 
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值