There are so many different religions in the world today
that it is difficult to keep track of them all. You are
interested in finding out how many different religions
students in your university believe in.
You know that there are n students in your university (0 < n ≤ 50000). It is infeasible for you to
ask every student their religious beliefs. Furthermore,
many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m
(0 ≤ m ≤ n(n − 1)/2) pairs of students and ask them
whether they believe in the same religion (e.g. they
may know if they both attend the same church). From
this data, you may not know what each person believes
in, but you can get an idea of the upper bound of how
many different religions can be possibly represented on
campus. You may assume that each student subscribes
to at most one religion.
Input
The input consists of a number of cases. Each case
starts with a line specifying the integers n and m. The
next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end
of input is specified by a line in which n = m = 0.
Output
For each test case, print on a single line the case number (starting with 1) followed by the maximum
number of different religions that the students in the university believe in.
Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
Sample Output
Case 1: 1
Case 2: 7
思路:
考察并查集,若有相同的宗教信仰就连到一起,最后统计一下根的个数。
代码:
#include <bits/stdc++.h>
#define N 50010
using namespace std;
int fa[N];
int find(int k){
if(fa[k]==k) return k;
fa[k]=find(fa[k]); //路径压缩
return fa[k];
}
int main(){
int n,m;
int cas=1;
while(cin>>n>>m){
if(n==0&&m==0) break;
//初始化并查集
for(int i=1;i<=n;i++)
fa[i]=i;
for(int i=0;i<m;i++){
int p,q;
scanf("%d %d",&p,&q);
int f1=find(p),f2=find(q);
if(f1!=f2) fa[f2]=f1;
}
//count根数
int cnt=0;
for(int i=1;i<=n;i++)
if(fa[i]==i) cnt++;
printf("Case %d: %d\n",cas++,cnt);
}
return 0;
}