04-树4 是否同一棵二叉搜索树

04-树5 Root of AVL Tree (25分)
An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.
Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer NN (\le 20≤20) which is the total number of keys to be inserted. Then NN distinct integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:

For each test case, print the root of the resulting AVL tree in one line.
Sample Input 1:

5
88 70 61 96 120
Sample Output 1:

70
Sample Input 2:

7
88 70 61 96 120 90 65
Sample Output 2:

88

题目大意:输入一段序列,构成AVL树,输出顶点

思路:用构成二叉搜索树的方法,当层次树大于或等于二的时候,旋转调整。

#include <iostream>

using namespace std;
#define Elemment int

typedef struct Avltree{
    Elemment data;
    struct Avltree* left;
    struct Avltree* right;
    int height;
}Avltree;

int getheight(Avltree* t)
{
    if (t == NULL)
        return -1;
    else
        return t->height;

}

int max(int leftHeight, int rightHeight)
{
    if (leftHeight >= rightHeight)
        return leftHeight;
    else
        return rightHeight;
}

Avltree* rrrotation(Avltree* t)
{
    Avltree* top = t->right;
    //t->right = top->left;
    //top->left = t;
    t->right = top->left;
    top->left = t;

    t->height = max(getheight(t->left), getheight(t->right)) + 1;
    top->height = max(getheight(top->right), getheight(top->left)) + 1;

    return top;
}

Avltree* llrotation(Avltree* t)
{
    Avltree* top = t->left;
    //t->left = top->right;
    //top->right = t;
    t->left = top->right;
    top->right = t;

    t->height = max(getheight(t->left), getheight(t->right)) + 1;
    top->height = max(getheight(top->left), getheight(top->right)) + 1;

    return top;
}

Avltree* rlrotation(Avltree* t)
{
    t->right = llrotation(t->right);

    return rrrotation(t); 
}



Avltree* lrrotation(Avltree* t)
{
    t->left = rrrotation(t->left);
    return llrotation(t);
}



Avltree* insert(Elemment x, Avltree* t)
{
    if (t == NULL)
    {
        t = new Avltree;
        t->data = x;
        t->height = 0;
        t->left = NULL;
        t->right = NULL;
    }

    else if (x < t->data)
    {
        t->left = insert(x, t->left);
        if (getheight(t->left) - getheight(t->right) == 2)
        {
            if (x < t->left->data)
            {
                t = llrotation(t);
            }

            else
            {
                t = lrrotation(t);
            }
        }


    }
    else if (x>t->data)
    {
        t->right = insert(x, t->right);
        if (getheight(t->right) - getheight(t->left) == 2)
        {
            if (x > t->right->data)
            {
                t = rrrotation(t);
            }
            else
            {
                t = rlrotation(t);
            }
        }
    }

    t->height = max(getheight(t->left), getheight(t->right)) + 1;
    return t;
}


void input()
{
    int num,data;
    Avltree* top = NULL;
    cin >> num;
    for (int i = 0; i < num; i++)
    {
        cin >> data;
        top = insert(data, top);
    }

    cout << top->data;
}

int main()
{
    input();


    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值