06-图2 Saving James Bond - Easy Version

This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).
Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.
Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers NN (\le 100≤100), the number of crocodiles, and DD, the maximum distance that James could jump. Then NN lines follow, each containing the (x, y)(x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.
Output Specification:

For each test case, print in a line “Yes” if James can escape, or “No” if not.
Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12
Sample Output 1:

Yes
Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12
Sample Output 2:

No

题目大意:在一个100*100的小岛上,中心为直径15的圆形出发点,现在给定james每一跳能力,判断james在中心出发时,能否有能力踩着鳄鱼过到岸边,鳄鱼的坐标会给出。

思路:两个鳄鱼间距离小于或等于james跳跃能力的点是互相连通的,构建图,深度优先搜索是否能到达与岸边相连的点(james到此点是否能跳到岸边)。

#include <iostream>
#include <vector>
#include <math.h>

using namespace std;

typedef struct vectex
{
    int x;
    int y;
    bool isvisit;
}vectex;

int n_crocodile;
float dis;
float square_dis = 0 ;
bool flag = false;

void DFS(vector<vector<bool>>& graph, vectex* v,int visit)
{
    if (v[visit].isvisit)
    {
        return;
    }
    v[visit].isvisit = true;
    if ((50 - abs(v[visit].x)) <= dis || (50 - abs(v[visit].y)) <= dis)
    {
        flag = true;
        return;
    }

    for (int i = 0; i < n_crocodile; i++)
    {
        if (v[i].isvisit == false && graph[visit][i] == true)
        {

            DFS(graph, v, i);
        }
    }
}

int main()
{


    cin >> n_crocodile;
    cin >> dis;
    square_dis = dis*dis;

    vectex* v = new vectex[n_crocodile];
    vector<vector<bool>> graph(n_crocodile, vector<bool>(n_crocodile, false));
    #pragma omp parallel for
    for (int i = 0; i < n_crocodile; i++)
    {
        cin >> v[i].x;
        cin >> v[i].y;
        v[i].isvisit = false;
    }

    for (int i = 0; i < n_crocodile; i++)
    {
        for (int j = i+1; j < n_crocodile; j++)
        {
            if (pow(v[i].x - v[j].x, 2) + pow(v[i].y - v[j].y, 2)  <= square_dis)
            {
                graph[i][j] = true;
                graph[j][i] = true;
            }
        }
    }
    for (int i = 0; i < n_crocodile; i++)
    {
        if ((float)(pow(v[i].x, 2) + pow(v[i].y, 2)) <= pow(dis + 7.5, 2))
        {
            DFS(graph, v, i);
        }
        if (flag == true)
            break;
    }
    if (flag == true)
        printf("Yes\n");
    else
    printf("No\n");


    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值