HDU-3486 Interviewe

原题链接

                                                                          Interviewe

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6430    Accepted Submission(s): 1530


Problem Description
YaoYao has a company and he wants to employ m people recently. Since his company is so famous, there are n people coming for the interview. However, YaoYao is so busy that he has no time to interview them by himself. So he decides to select exact m interviewers for this task.
YaoYao decides to make the interview as follows. First he queues the interviewees according to their coming order. Then he cuts the queue into m segments. The length of each segment is , which means he ignores the rest interviewees (poor guys because they comes late). Then, each segment is assigned to an interviewer and the interviewer chooses the best one from them as the employee.
YaoYao’s idea seems to be wonderful, but he meets another problem. He values the ability of the ith arrived interviewee as a number from 0 to 1000. Of course, the better one is, the higher ability value one has. He wants his employees good enough, so the sum of the ability values of his employees must exceed his target k (exceed means strictly large than). On the other hand, he wants to employ as less people as possible because of the high salary nowadays. Could you help him to find the smallest m?
 

Input
The input consists of multiple cases.
In the first line of each case, there are two numbers n and k, indicating the number of the original people and the sum of the ability values of employees YaoYao wants to hire (n≤200000, k≤1000000000). In the second line, there are n numbers v1, v2, …, vn (each number is between 0 and 1000), indicating the ability value of each arrived interviewee respectively.
The input ends up with two negative numbers, which should not be processed as a case.
 

Output
For each test case, print only one number indicating the smallest m you can find. If you can’t find any, output -1 instead.
 

Sample Input
  
  
11 300 7 100 7 101 100 100 9 100 100 110 110 -1 -1
 

Sample Output
  
  
3
Hint
We need 3 interviewers to help YaoYao. The first one interviews people from 1 to 3, the second interviews people from 4 to 6, and the third interviews people from 7 to 9. And the people left will be ignored. And the total value you can get is 100+101+100=301>300.

先用ST进行预处理区间最大值。另i为组数,i从1遍历到n,求出ability values,比较是否大于k.当然这肯定会超时,经过观察,会有这样一个现象,a, b (b >= a),a <= k <= b,所有的n/k相等。也就是说求出i组时的ability values= S,并且n/(i+1)==n/i, 那么当求i+1组时的能力值时可以把S直接拿过来用,在加上多出的一个区间的最大值。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#define maxn 200005
using namespace std;
typedef long long ll;

int d[maxn][20], n, k;
void ST(){
	for(int i = 0; i < n; i++)
	 scanf("%d", &d[i][0]); 
	for(int j = 1; (1<<j) <= n; j++)
	  for(int i = 0; i + (1<<j) <= n; i++)
	   d[i][j] = max(d[i][j-1], d[i+(1<<(j-1))][j-1]);
} 
int main(){
	
//	freopen("in.txt", "r", stdin); 
	while(scanf("%d%d", &n, &k) == 2){
		if(n < 0 && k < 0)
		 break;
		ST();
		ll s = 0;
		int sign = 0, v = -1;
		for(int i = 1; i <= n; i++){
			int p = 0, h = n / i, j = 0, b = i;
			if(v != h){
			 v = h;
			 s = 0;
		   }
			else{
			 j = (i-1) * h;
			 b = 1;
		   }
		    while(1<<(1+p) <= h)
				p++;
			for(; b; j += h, b--){
				s += max(d[j][p], d[j+h-(1<<p)][p]);
			}
			if(s > k){
				sign = 1;
				printf("%d\n", i);
				break;
			}
		}
		if(sign == 0)
		 puts("-1");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值