N - HUD 3486 二分+RMQ

YaoYao has a company and he wants to employ m people recently. Since his company is so famous, there are n people coming for the interview. However, YaoYao is so busy that he has no time to interview them by himself. So he decides to select exact m interviewers for this task. 
YaoYao decides to make the interview as follows. First he queues the interviewees according to their coming order. Then he cuts the queue into m segments. The length of each segment is  , which means he ignores the rest interviewees (poor guys because they comes late). Then, each segment is assigned to an interviewer and the interviewer chooses the best one from them as the employee. 
YaoYao’s idea seems to be wonderful, but he meets another problem. He values the ability of the ith arrived interviewee as a number from 0 to 1000. Of course, the better one is, the higher ability value one has. He wants his employees good enough, so the sum of the ability values of his employees must exceed his target k (exceed means strictly large than). On the other hand, he wants to employ as less people as possible because of the high salary nowadays. Could you help him to find the smallest m? 

Input

The input consists of multiple cases. 
In the first line of each case, there are two numbers n and k, indicating the number of the original people and the sum of the ability values of employees YaoYao wants to hire (n≤200000, k≤1000000000). In the second line, there are n numbers v1, v2, …, vn (each number is between 0 and 1000), indicating the ability value of each arrived interviewee respectively. 
The input ends up with two negative numbers, which should not be processed as a case. 

Output

For each test case, print only one number indicating the smallest m you can find. If you can’t find any, output -1 instead.

Sample Input

11 300
7 100 7 101 100 100 9 100 100 110 110
-1 -1

Sample Output

3

Hint

We need 3 interviewers to help YaoYao. The first one interviews people from 1 to 3, the second interviews people from 4 to 6, 
and the third interviews people from 7 to 9. And the people left will be ignored. And the total value you can get is 100+101+100=301>300.

题意:有n个人排队应聘,每个人有一个能力值,然后老板要把这些人分成m段,如果不能整除多出来就后面的人就不要了,然后从这m段里面选择每段的最大能力值加起来看是否能够大于老板需要的目标k,因为薪资问题,尽可能少录取人,所以找出满足条件的最小的m。

输入:一共有n个人,我们所需要的能量之和是 k,(当n和k不为负数是)以下n个数分别代表每个人的能量,

输出:我们最少需要几个人就可以达到所需要的能量;


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <set>
#include <vector>
#include <map>
#include <queue>
#include <set>
#include <algorithm>
#define ll long long
using namespace std;
const int maxn = 200010;
ll n, k;
int mapp[maxn];
int maxx[maxn][30];
//RMQ初始化;
void RMQ()
{
    for(int i=0; i<n; i++)
        maxx[i][0] = mapp[i];
    for(int j=1; (1<<j)<=n; j++)
    {
        for(int i=0; i+(1<<j)-1<n; i++)
        {
            maxx[i][j] = max(maxx[i][j-1], maxx[i+(1<<(j-1))][j-1]);
        }
    }
}
//查询从l到r的最大值;
int rmq(int l, int r)
{
    int k = 0;
    while(1<<(k+1)<=(r-l+1))
    {
        k++;
    }
    return max(maxx[l][k], maxx[r-(1<<k)+1][k]);
}
int main()
{
    while(scanf("%lld%lld", &n, &k)!=EOF&&(n>0||k>=0))
    {
        int maxxx = 0, sum = 0;
        //输入每个人的能量,并找出最大的能量值;
        for(int i=0; i<n; i++)
        {
            scanf("%d", &mapp[i]);
            sum+=mapp[i];
            if(mapp[i]>maxxx)
            {
                maxxx = mapp[i];
            }
        }
        //如果所有人的能量之和都不没有需要的能量值大,就说明找不到符合要求的结果,输出-1;
        if(sum<k)
        {
            printf("-1\n");
            continue;
        }
        RMQ();//RMQ初始化;
        int zu = k/maxxx;//组数从组数量最少的开始找;
        int num, summ;
        if(zu==0)
            zu = 1;
        //从组数最少开始遍历;
        for(; zu<=n; zu++)
        {
            num = n/zu;//一个组里的人数;
            summ = 0;
            for(int i=1; i<=zu; i++)
            {
                summ+=rmq((i-1)*num, i*num-1);//summ加从(i-1)*num个人到第i*num-1个人的最大值
            }
            //已经拥有的能量大于我们需要的能量;退出循环;
            if(summ>k)
            {
                break;
            }
        }
        printf("%d\n",zu);
    }
    return 0;
}

二分: 

#include<stdio.h>
#include<string.h>
const int MAX = 200010;
#define min(a,b) a<b?a:b
#define max(a,b) a>b?a:b
int dp[MAX][30],a[MAX];
int k;
void init(int n)
{
    memset(maxx,0,sizeof(maxx));
	int i,j,m;
	for(i=1; i<=n; i++)
	{
		maxx[i][0]=mapp[i];
	}
	for(j=1,m=1; m<=n; m<<=1,j++)
    {
		for(i=n;i>=1;i--)
		{
			if(i+(1<<(j-1))<=n)
				maxx[i][j]=max(maxx[i][j-1],maxx[i+(1<<(j-1))][j-1]);
		}
    }
}
int RMQ(int l,int r)
{
	int i,j,k,a;
	k=r-l+1;
	for(i=0,j=1; j<=k; j<<=1,i++)
	{
		a=max(maxx[l][i],maxx[r-j+1][i]);
	}
	return a;
}
int getmax(int per,int mid)
{
     int i;
	 int ans=0;
	 for(i=1; i<=mid; i++)
	 {
		ans+=RMQ((i-1)*per+1,i*per);
		if(ans>k) 
        return ans;
	 }
	 return 0;
}
int main()
{
	int n,i;
	while(scanf("%d%d",&n,&k),n>0)
	{
		int sum=0;
		int maxxx=0;
        //输入每个人的能量,并取最大能量值;
		for(i=1; i<=n; i++)
        {
			scanf("%d",&mapp[i]);
			if(mapp[i]>maxxx) 
                maxxx = mapp[i];
			sum+=mapp[i];
		}
        //如果最大的能量大于我们需要的能量和,就把所有的人分为一组,取最大的能量值即可;
		if(maxxx>k)
        { 
            printf("1\n");
            continue;
        }
        //如果所有人能量和少于或等于我们所有需要的能量和,即说明没有符合要求的答案,输出-1;
		if(sum<=k)
		{
            printf("-1\n");
            continue;
        }
		init(n);
		int  l=1,r=n,mid;
		int ans=0;
		while(l<=r)
		{
            mid=(l+r)>>1;
            int per=n/mid;
			int tmp=getmax(per,mid);
			if(tmp>k)
			{
				r=mid-1;
				ans=mid;
			}
		    else 
                l=mid+1;
		}
		printf("%d\n",ans);
	}
	return 0;
}

 

这是一个使用Java语言编写的应用程序的命令行运行指令。该程序是一个消息队列中间件的Broker,使用了RocketMQ框架实现。其中的参数含义如下: -server:使用JVM的server模式。在多核CPU上提高性能。 -Xms2g:JVM启动时堆内存的最小值为2G。 -Xmx2g:JVM堆内存的最大值为2G。 -XX:+UseG1GC:使用G1垃圾回收器。 -XX:G1HeapRegionSize=16m:G1垃圾回收器内存区域的大小为16M。 -XX:G1ReservePercent=25:预留25%的空间以避免太满引发的性能问题。 -XX:InitiatingHeapOccupancyPercent=30:G1在堆内存使用达到30%时会触发垃圾回收。 -XX:SoftRefLRUPolicyMSPerMB=0:清除软引用的时间间隔为0,即软引用的对象一旦没有被使用就会被立即清除。 -verbose:gc:打印GC日志。 -Xloggc:/dev/shm/rmq_srv_gc_%p_%t.log:将GC日志输出到/dev/shm/rmq_srv_gc_%p_%t.log文件中。 -XX:+PrintGCDetails:打印GC详细信息。 -XX:+PrintGCDateStamps:打印GC时间戳。 -XX:+PrintGCApplicationStoppedTime:打印应用程序停止时间。 -XX:+PrintAdaptiveSizePolicy:打印自适应策略的信息。 -XX:+UseGCLogFileRotation:启用GC日志文件轮换。 -XX:NumberOfGCLogFiles=5:GC日志文件轮换时保留的文件数目。 -XX:GCLogFileSize=30m:GC日志文件的大小为30M。 -XX:-OmitStackTraceInFastThrow:关闭快速抛出异常时的栈信息。 -XX:+AlwaysPreTouch:在JVM启动时预先分配堆内存。 -XX:MaxDirectMemorySize=15g:最大直接内存大小为15G。 -XX:-UseLargePages:不使用大页面。 -XX:-UseBiasedLocking:不使用偏向锁。 -Drocketmq.client.logUseSlf4j=true:使用SLF4J作为日志框架。 -c ../conf/broker.conf:指定Broker的配置文件路径。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值