POJ 2105 IP Address

Problem Description
Suppose you are reading byte streams from any device, representing IP addresses. Your task is to convert a 32 characters long sequence of ‘1s’ and ‘0s’ (bits) to a dotted decimal format. A dotted decimal format for an IP address is form by grouping 8 bits at a time and converting the binary representation to decimal representation. Any 8 bits is a valid part of an IP address. To convert binary numbers to decimal numbers remember that both are positional numerical systems, where the first 8 positions of the binary systems are:
27 26 25 24 23 22 21 20

128 64 32 16 8 4 2 1

Input
The input will have a number N (1<=N<=9) in its first line representing the number of streams to convert. N lines will follow.

Output
The output must have N lines with a doted decimal IP address. A dotted decimal IP address is formed by grouping 8 bit at the time and converting the binary representation to decimal representation.

Sample Input
4
00000000000000000000000000000000
00000011100000001111111111111111
11001011100001001110010110000000
01010000000100000000000000000001

Sample Output
0.0.0.0
3.128.255.255
203.132.229.128
80.16.0.1

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>

int main(){
    int n;
    scanf("%d",&n);getchar();
    while(n--){
        char str[35];
        int i;
        gets(str);
       // for(i=0;i<32;i++)
         //   scanf("%c",&str[i]);
        int sum[4];
        int j;
        //printf("!!!\n");
        for(int j=3;j>=0;j--){
                sum[j]=0;
            for(i=1;i<=8;i++){
                if(str[(j+1)*8-i]=='1'){
                    sum[j]+=pow(2,i-1);
                /**printf("sum[%d]=%d\n",j,sum[j]);putchar(str[(j+1)*8-i]);
                putchar(10);**/
                }
            }
        }
        printf("%d.%d.%d.%d\n",sum[0],sum[1],sum[2],sum[3]);
        for(i=0;i<4;i++)
            sum[i]=0;
    }
    return 0;
}
#include <stdio.h>
#include <stdlib.h>
#include <math.h>

int a[8]={1,2,4,8,16,32,64,128};
int main(){
    int n;
    scanf("%d",&n);
    while(n--){
        char str[35];



            scanf("%s",str);
        int i,sum[5],j=0;
        for(i=31;i>=0;i--){
            if(i%8==7){
                sum[++j]=0;
            }
            if(str[i]=='1'){
                sum[j]+=a[7-i%8];
            }
        }
        printf("%d.%d.%d.%d\n",sum[4],sum[3],sum[2],sum[1]);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

谙忆

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值