POJ 1978 Hanafuda Shuffle

Hanafuda Shuffle

Description

There are a number of ways to shuffle a deck of cards. Hanafuda shuffling for Japanese card game 'Hanafuda' is one such example. The following is how to perform Hanafuda shuffling. 

There is a deck of n cards. Starting from the p-th card from the top of the deck, c cards are pulled out and put on the top of the deck, as shown in Figure 1. This operation, called a cutting operation, is repeated. 

Write a program that simulates Hanafuda shuffling and answers which card will be finally placed on the top of the deck. 
 
Figure 1: Cutting operation

Input

The input consists of multiple data sets. Each data set starts with a line containing two positive integers n (1 <= n <= 50) and r (1 <= r <= 50); n and r are the number of cards in the deck and the number of cutting operations, respectively. 

There are r more lines in the data set, each of which represents a cutting operation. These cutting operations are performed in the listed order. Each line contains two positive integers p and c (p + c <= n + 1). Starting from the p-th card from the top of the deck, c cards should be pulled out and put on the top. 

The end of the input is indicated by a line which contains two zeros. 

Each input line contains exactly two integers separated by a space character. There are no other characters in the line.

Output

For each data set in the input, your program should write the number of the top card after the shuffle. Assume that at the beginning the cards are numbered from 1 to n, from the bottom to the top. Each number should be written in a separate line without any superfluous characters such as leading or following spaces.

Sample Input

5 2
3 1
3 1
10 3
1 10
10 1
8 3
0 0

Sample Output

4
4
题目大意:给出一摞卡片,自底向上按照1至N排列。给出两个数p和c,交换顶部的前q - 1张卡片和第q至q + c - 1张卡片,求r次操作后最上面的一张牌上面的数字是多少。

解题思路:用栈模拟整个过程即可。

代码如下:

#include <cstdio>
#include <stack>

using namespace std;
stack<int>s1,s2,s3;
void clear(stack<int> s)
{
	while(s.size())
		s.pop();
}

int main()
{
	
	int n,r,p,c;
	while(scanf("%d %d",&n,&r) != EOF && (n || r)){
		clear(s1);
		clear(s2);
		clear(s3);
		for(int i = 1;i <= n;i++)
			s1.push(i);
		for(int i = 0;i < r;i++){
			scanf("%d %d",&p,&c);
			for(int j = 1;j < p;j++){
				s2.push(s1.top());
				s1.pop();
			}
			for(int j = 1;j <= c;j++){
				s3.push(s1.top());
				s1.pop();
			}
			for(int j = 1;j < p;j++){
				s1.push(s2.top());
				s2.pop();
			}
			for(int j = 1;j <= c;j++){
				s1.push(s3.top());
				s3.pop();
			}
		}
		
		printf("%d\n",s1.top());
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值