HDOJ 1241 Oil Deposits(DFS)

Oil Deposits




Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2 2
题目大意:给出一个m * n的土地,其中@代表有石油,*代表缺乏石油,如果两块油田相邻(8个方向),则说明它们是连通的,否则是不连通的。求出给出的土地上有多少连通的油田。

解题思路:此题与POJ 2386 Lake Counting做法一致,即用DFS求连通块的数量。我们可以从任意的@开始,不断地把邻接部分用*代替,表示已经DFS过,1次DFS后所有与初始@相邻的@都被替换成了*,因此直到图中不再存在@为止,所进行的DFS次数就是答案。

代码如下:

#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

const int maxn = 105;
const int maxm = 105;

char oil[maxm][maxn];

int n,m;

void dfs(int x,int y)
{
    oil[x][y] = '*';
    for(int dx = -1;dx <= 1;dx++){
        for(int dy = -1;dy <= 1;dy ++){
            int nx = x + dx;
            int ny = y + dy;
            if(0 <= nx && nx < m && 0 <= ny && ny < n && oil[nx][ny] != '*'){
                dfs(nx,ny);
            }
        }
    }
    return ;
}

int main()
{
    while(scanf("%d %d",&m,&n) != EOF && (n || m)){
        int ans = 0;
        for(int i = 0;i < m;i++){
            scanf("%s",oil[i]);
        }
        for(int i = 0;i < m;i++){
            for(int j = 0;j < n;j++){
                if(oil[i][j] == '@'){
                    dfs(i,j);
                    ans++;
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值