UVaOJ 10003 Cutting Sticks(区间DP)

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery,Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of workrequires that they only make one cut at a time.

It is easy to notice that different selections in the order of cutting can led to different prices. Forexample, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end.There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a priceof 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6.Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 =20, which is a better price.

Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.

Input

The input will consist of several input cases. The first line of each test case will contain a positivenumber l that represents the length of the stick to be cut. You can assume l < 1000. The next line willcontain the number n (n < 50) of cuts to be made.

The next line consists of n positive numbers ci (0 < ci < l) representing the places where the cutshave to be done, given in strictly increasing order.

An input case with l = 0 will represent the end of the input.

Output

You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost ofcutting the given stick. Format the output as shown below.

Sample Input

100

3

25 50 75

10

4

4 5 7 8

0

Sample Output

The minimum cutting is 200.

The minimum cutting is 22.

题目大意:你的老板要你切一些木棒,以不同的顺序切木棒有不同的花费。例如一根长为10的木棒,要在距离木棒一端2、4、7的位置切断,如果先切2,再切4,最后切7,那么花费为10 + 8 + 6 = 24;而如果换一个顺序切,譬如先切4,再切2,最后切7,那么总花费就是10 + 6 + 4 = 20。现在给你木棒的长度以及切割点的位置,求切木棒的最小花费。

解题思路:刚看到这个问题的我是懵逼的,后来进过一波反向思考,就搞懂了。我们可以把整个过程反过来,将问题看做合并木棒使得总花费最小(与合并石子的问题一样),而每次合并木棒的花费就是两根木棒的长度之和。所以求出每根木棒的长度,然后区间DP即可。

代码如下:

#include <cstdio>
#include <algorithm>
#include <climits>
#include <cstring>
#include <cmath>

using namespace std;

const int maxn = 55;

int dp[maxn][maxn];
int stick[maxn],sum[maxn],pos[maxn];

int main()
{
    int n,len;
    while(scanf("%d",&len) != EOF && len){
        scanf("%d",&n);
        for(int i = 1;i <= n;i++){
            scanf("%d",&pos[i]);

        }
        for(int i = 1;i <= n;i++){
            stick[i] = pos[i] - pos[i - 1];
            sum[i] = sum[i - 1] + stick[i];
        }
        stick[n + 1] = len - pos[n];
        sum[n + 1] = sum[n] + stick[n + 1];
        memset(dp,0,sizeof(dp));
        for(int l = 1;l <= n;l++){
            for(int i = 1;i <= n - l + 1;i++){
                int j = i + l;
                dp[i][j] = INT_MAX;
                for(int k = i;k <= j;k++){
                    dp[i][j] = min(dp[i][j],dp[i][k] + dp[k + 1][j] + sum[j] - sum[i - 1]);
                }
            }
        }
        printf("The minimum cutting is %d.\n",dp[1][n + 1]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值