10003 - Cutting Sticks
Time limit: 3.000 seconds
You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery, Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work requires that they only make one cut at a time.
10003 - Cutting Sticks
Time limit: 3.000 secondsIt is easy to notice that different selections in the order of cutting can led to different prices. For example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end. There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6. Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 = 20, which is a better price.
Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.
Input
The input will consist of several input cases. The first line of each test case will contain a positive number l that represents the length of the stick to be cut. You can assume l < 1000. The next line will contain the number n ( n < 50) of cuts to be made.The next line consists of n positive numbers ci ( 0 < ci < l) representing the places where the cuts have to be done, given in strictly increasing order.
An input case with l = 0 will represent the end of the input.
Output
You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of cutting the given stick. Format the output as shown below.Sample Input
100 3 25 50 75 10 4 4 5 7 8 0
Sample Output
The minimum cutting is 200. The minimum cutting is 22.
Miguel Revilla
2000-08-21
题目大意:
给定一个l长得木棍,要把它从给定的n个点截断,每截断一次需要的费用为木棍的长度。
求截断这个木棍所要花费的最小代价。
题目分析:
典型的区间DP,要额外添加2个点:0和l,于是区间从1不断扩展到n+1,dp[i][j]代表点i到点j所要花费的最小代价。
源代码:
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#define min(a,b) (((a) < (b)) ? (a) : (b))
const int INF = 1e9;
int a[60];
int dp[60][60];
int main() {
int l, n;
while (scanf("%d", &l) && l) {
scanf("%d", &n);
for (int i = 1; i <= n; ++i)
scanf("%d", &a[i]);
a[0] = 0, a[n+1] = l;
n += 1;
memset(dp, 0, sizeof(dp));
for (int i = 0; i <= n; ++i) {
for (int j = 0; j <= n; ++j)
dp[i][j] = INF;
dp[i][i] = 0;
}
for (int i = 0; i < n; ++i)
dp[i][i+1] = 0;
for (int p = 2; p <= n; ++p)
for (int i = 0, j = p; j <= n; ++i, ++j)
for (int k = i; k < j; ++k)
dp[i][j] = min(dp[i][j], dp[i][k] + dp[k][j] + a[j] - a[i]);
printf("The minimum cutting is %d.\n", dp[0][n]);
}
return 0;
}