POJ 3070 Fibonacci(矩阵快速幂)

Fibonacci

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875
题目大意:求第n个Fibonacci数的后四位。

解题思路:矩阵快速幂。刚开始把初始化函数放在外面了,导致WA了一次。。

代码如下:

#include <cstdio>
#include <cstring>
#define MOD 10000
typedef long long ll;
const int maxn = 2;
ll n;
struct Matrix
{
    ll mat[maxn][maxn];
    Matrix operator * (const Matrix m)const
    {
        Matrix temp;
        for(int i = 0;i < maxn;i++){
            for(int j = 0;j < maxn;j++){
                temp.mat[i][j] = 0;
                for(int k = 0;k < maxn;k++){
                    temp.mat[i][j] += (mat[i][k] * m.mat[k][j]) ;
                    temp.mat[i][j] %= MOD;
                }
            }
        }
        return temp;
    }
};

ll Pow(Matrix& m,int k)
{
    Matrix ans;
    memset(ans.mat,0,sizeof(ans.mat));
    for(int i = 0;i < maxn;i++){
        ans.mat[i][i] = 1;
    }
    while(k){
        if(k & 1)
            ans = ans * m;
        k >>= 1;
        m = m * m;

    }
    return ans.mat[0][1];
}

void init(Matrix& m)
{

    m.mat[0][0] = m.mat[0][1] = m.mat[1][0] = 1;
    m.mat[1][1] = 0;
}

int main()
{
    Matrix m;
    while(scanf("%I64d",&n) != EOF && n != -1){
        init(m);
        printf("%I64d\n",Pow(m,n));
    }
    return 0;
}


Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值