使用单调栈优化解题 POJ2559

 POJ 2559

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:


Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

struct Node
{
   ll val;
    ll len;
};

stack<Node> s;

int main()
{
    long long temp,Max,n,i,m;
    Node q;
    while(scanf("%lld",&n)!=EOF)
    {
        if(n==0) break;
        Max=0;
        for(i=0;i<n;i++)
        {
            scanf("%lld",&q.val);
            q.len=1;
            int has_del_num=0;
            if(s.empty())
            {
                s.push(q);
            }
            else if(q.val<=(s.top()).val)
            {
                while(!s.empty()&&q.val<(s.top().val))
                {
                    s.top().len+=has_del_num;//画图即可,可以得到当前矩形高可以组成矩形的长度
                    has_del_num=s.top().len;
                    Max=max(s.top().val*s.top().len,Max);
                    s.pop();
                }
                q.len+=has_del_num;
                s.push(q);
            }
            else
                s.push(q);
        }
        int has_del_num=0;
        while(!s.empty())
        {
            (s.top()).len+=has_del_num;
            m=(s.top()).val*(s.top()).len;
            if(m>Max) Max=m;
            has_del_num=s.top().len;
            s.pop();
        }
        cout<<Max<<endl;
    }
}

贴出自己写的代码

大体思路是这样的,对于给定的一个矩形i 找i左边的比他大的连接的矩形的个数,然后找右面的,在这个题里面我使用了栈来表示一个单调栈,通过结构数组来维护每个矩形的相关信息,若出现一个比栈顶元素小的矩形,则开始向前查找比当前的矩形晓得元素,,记录下每个矩形高的长度,然后pop掉,这样的话每个矩形的len就是这个矩形后面能够保持这个矩形高的矩形的个数,,这样在最后查找的时候就很容易计算各个矩形高组成矩形的面积啦

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值