HDU 1114 Piggy-Bank 存钱罐

原题: http://acm.hdu.edu.cn/showproblem.php?pid=1114

题目:

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16228 Accepted Submission(s): 8177

Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.

Output
Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.

Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

思路:

给定已知背包容量,给定已知货物价格和重量,求出装满背包容量的时候价值最少的情况。

常见的背包问题的状态转移方程都是用max函数得到最优解,而本例其实只需要把max改成min就行了,但是前提条件是要将dp数组初始化为无穷大,这样min才不会每次都得到0。

不习惯用min的也可以用max,只需要把dp初始化成无穷小,所有金币的面值为负数,求得的满足条件的最大负数再取绝对值就是所求答案。

代码:

#include <iostream>
#include"string.h"
#include"cstdio"
#include"stdlib.h"
#include"algorithm"

using namespace std;

const int N = 10005;  //最大件数
const int M = 10005;  //最大重量
int weight[N];
int value[N];
int dp[M];
int mi,ma;
int n,m;
void init()
{
    memset(value,0,sizeof(value));
    memset(weight,0,sizeof(weight));
//    memset(dp,0,sizeof(dp));

    for(int j=0; j<=m+1; j++)
    {
        dp[j]=-12345678;
    }
}
void backpack()
{
    for(int i=1; i<=n; i++) //当前放的件数
    {
        for(int j=weight[i]; j<=m; j++) //当前重量
        {
            dp[j]=max(dp[j],dp[j-weight[i]]+value[i]);
        }
    }
}


int main()
{
    int tt;
    scanf("%d",&tt);
    while(tt--)
    {
        int t1,t2;
        scanf("%d %d",&t1,&t2);
        m=t2-t1;
        init();

        scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            scanf("%d %d",&value[i],&weight[i]);
            value[i]=-value[i];
        }
        dp[0]=0;
        backpack();
        if (dp[m] == -12345678)    //并不能装满
            printf("This is impossible.\n");
        else
            printf("The minimum amount of money in the piggy-bank is %d.\n", -dp[m]);

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值