HDU1518:Square(DFS)

Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no yes

 


<pre name="code" class="html">#include<iostream>
#include<cstring>
using namespace std;
int book[25];
int a[25];
int n;
int sum;
int flag;

/*在确定边的长度时,某一条边进行搜索时,
step之前的值一定不可取,
因为要么被标记,要么超过边长 
*/ 
void dfs(int edge,int cnt,int step)//edge代表第几条边,cnt代表当前边的长度 
{
	if(flag)return ;
	if(edge==5)
	{
		flag=1;
		return ;
	}
	
	if(cnt==sum)
	{
		dfs(edge+1,0,0);
	} 
	
	 for(int i=step+1;i<=n;i++)
	 {
	 	if(!book[i]&&cnt+a[i]<=sum)
	 	{
	 		book[i]=1;
	 		dfs(edge,cnt+a[i],i);
	 		book[i]=0;
		 }
	 }
	 

}
int main()	
{
	ios::sync_with_stdio(false);
	int t;
	cin>>t;
	
	while(t--)
	{
		memset(book,0,sizeof(book));
		flag=0;
		
		cin>>n;
		
		sum=0;
		for(int i=1;i<=n;i++)
		{
			cin>>a[i];
			sum+=a[i];
		}
		
		if(sum%4!=0)
		{
			cout<<"no"<<endl;	
			continue;
		}
		
		sum/=4;
		int ccc=0;
		for(int i=1;i<=n;i++)
		{
			if(a[i]>sum)
			{
				ccc=1;
			}
		}
		
		if(ccc)
		{
			cout<<"no"<<endl;
			continue;
		}
		
		
		
		dfs(1,0,1);//按照边的顺序进行搜索 
	
		
		if(flag)
		{
			cout<<"yes"<<endl;
		}
		if(!flag)
		{
			cout<<"no"<<endl;
		}
		
	}	
	
	
	return 0;
}



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值