1162

提交: 1200   解决: 206
[ 提交][ 状态][ 讨论版]

题目描述

Give you a number named N; please tell me how many ways to  arrive N use two square 
integers.

输入

There are many of test cases. For each test case, just one line  contains a number  N 
(1<=N<=1000000).
Proceed to the end of file.

输出

If there is no way to arrive N use two square numbers, please output  “No Solution!”, and 
else output an integer indicating the ways number.

样例输入

50
9

样例输出

2
1

提示

There is two ways to arrive number 50:

First: 50 = 1 + 49

Second: 50 = 25 + 25

There is one way to arrive number 9: 9 = 0 + 9

来源

2012黑龙江省赛


#include<stdio.h>
#include <string.h>
int N[1000001];
int main()

{  memset(N,0,sizeof(N));
    int i,j,k;
    for (i=0;i<=1000;i++){
      for (j=i;j<=1000;j++){
        if ((i*i+j*j)>1000000) break;
         N[i*i+j*j]++;
         }
         }
        while(scanf("%d",&k)!=EOF)
        {
            if(N[k])printf("%d\n",N[k]);
            else printf("No Solution!\n");
        }
        return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值