POJ 2299 Ultra-QuickSort 树状数组

20 篇文章 0 订阅

题目链接:poj2299

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 59159 Accepted: 21893

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 , 

Ultra-QuickSort produces the output 
0 1 4 5 9 . 

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence. 

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

题意:对于n个数进行从小到大的排序,每次交换相邻2个数,问需要交换多少次。

题目分析:树状数组求逆序数模板,需要注意的是数据范围999999999,需要用long long,不同于1到n的逆序数求法,这里需要离散化后再进行处理。

//
//  main.cpp
//  POJ2299
//
//  Created by teddywang on 2017/2/11.
//  Copyright © 2017年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
using namespace std;
typedef  int ll;
ll s[500010];
ll p[500010];
ll c[500010],r[500010];
ll n;
struct node{
    ll val;
    int pos;
}t[500010];

bool cmp(node &a,node &b)
{
    return a.val<b.val;
}

ll lowbit(ll x)
{
    return x&(-x);
}

void update(ll x,ll num)
{
    while(x<=n)
    {
        c[x]+=num;
        x+=lowbit(x);
    }
}

ll getsum(ll x)
{
    ll ans=0;
    while(x>0)
    {
        ans+=c[x];
        x-=lowbit(x);
    }
    return ans;
}
int main()
{
    while(cin>>n&&n)
    {
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&t[i].val);
            t[i].pos=i;
        }
        sort(t+1,t+n+1,cmp);
        for(int i=1;i<=n;i++)
        {
            s[t[i].pos]=i;
        }
        long long int ans=0;
        for(int i=n;i>=1;i--)
        {
            r[s[i]]=getsum(s[i]);
            ans+=r[s[i]];
            update(s[i],1);
        }
        printf("%lld\n",ans);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值