HDOJ 5533-Hidden String

Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 582    Accepted Submission(s): 308


Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

Input
The first line contains a integer  T  indicating the total number of test cases. Each test case begins with an integer  n , denoting the number of stars in the sky. Following  n  lines, each contains  2  integers  xi,yi , describe the coordinates of  n  stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
  
  
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

Sample Output
  
  
NO YES NO
 

Source

题目大意
题目大意就是就是给出一些点的坐标,保证这些坐标x,y都是整数(这个很重要),然后输出是不是可以组成正多边形。
解题思路
我们知道坐标轴的单位长度数1,对角线长是根号2,所以除了正四边形就是正方形以外都不满足这个条件。所以只要判断输入点的多少,在判断是不是正方形就行了


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<cmath>
using namespace std;
struct node
{
	int x,y;
}num[10000];
bool cmp(node x1,node y1)
{
	if(x1.x==y1.x)
	{
		return x1.y<y1.y;
	}
	return x1.x<y1.x;
}
double ji(int x1,int y1,int x2,int y2)
{
	return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		int t;
		scanf("%d",&t);
		for(int i=0;i<t;i++)
		{
			scanf("%d%d",&num[i].x,&num[i].y);
		}
		if(t!=4)
		{
			printf("NO\n");
		}
		else
		{
			sort(num,num+4,cmp);
			double map1,map2,map3,map4,map5,map6;
			map1=ji(num[0].x,num[0].y,num[1].x,num[1].y);
			map2=ji(num[0].x,num[0].y,num[2].x,num[2].y);
			map3=ji(num[2].x,num[2].y,num[3].x,num[3].y);
			map4=ji(num[1].x,num[1].y,num[3].x,num[3].y);
			map5=ji(num[0].x,num[0].y,num[3].x,num[3].y);
			map6=ji(num[1].x,num[1].y,num[2].x,num[2].y);
			if(map1==map2&&map1==map4&&map2==map3&&map3==map4&&map5==map6)
			printf("YES\n");
			else
			printf("NO\n");			
		}
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值