The Famous Clock

The Famous Clock

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 1
描述

Mr. B, Mr. G and Mr. M are now in Warsaw, Poland, for the 2012’s ACM-ICPC World Finals Contest. They’ve decided to take a 5 hours training every day before the contest. Also, they plan to start training at 10:00 each day since the World Final Contest will do so. The scenery in Warsaw is so attractive that Mr. B would always like to take a walk outside for a while after breakfast. However, Mr. B have to go back before training starts, otherwise his teammates will be annoyed. Here is a problem: Mr. B does not have a watch. In order to know the exact time, he has bought a new watch in Warsaw, but all the numbers on that watch are represented in Roman Numerals. Mr. B cannot understand such kind of numbers. Can you translate for him?

输入
Each test case contains a single line indicating a Roman Numerals that to be translated. All the numbers can be found on clocks. That is, each number in the input represents an integer between 1 and 12. Roman Numerals are expressed by strings consisting of uppercase ‘I’, ‘V’ and ‘X’. See the sample input for further information.
输出
For each test case, display a single line containing a decimal number corresponding to the given Roman Numerals.
样例输入
I
II
III
IV
V
VI
VII
VIII
IX
X
XI
XII
样例输出
Case 1: 1
Case 2: 2
Case 3: 3
Case 4: 4
Case 5: 5
Case 6: 6
Case 7: 7
Case 8: 8
Case 9: 9
Case 10: 10
Case 11: 11
Case 12: 12

import java.util.Scanner;


public class Main {

	public static void main(String[] args) {
		Scanner scanner=new Scanner(System.in);
		int count=0;
		String arr[]={"I","II","III","IV","V","VI","VII","VIII","IX","X","XI","XII"};
		while(scanner.hasNext())
		{
			String string=scanner.nextLine();
			System.out.print("Case "+(++count)+": ");
			for(int i=0;i<12;i++)
			{
				if(string.equals(arr[i]))
				{
					System.out.println(i+1);
					break;
				}
			}
		}
	}

}


Sure! The Rosenthal Effect, also known as the Pygmalion Effect, refers to the phenomenon where high expectations lead to improved performance. In the world of education, this effect is often observed in the classroom where teachers' expectations of their students can have a significant impact on how well they perform. The most famous experiment on the Rosenthal Effect was conducted by Robert Rosenthal and Lenore Jacobson in 1968. The experiment involved teachers being given a list of students who were supposed to be "intellectual bloomers," i.e., students who were expected to make significant gains in their academic performance over the course of the academic year. In reality, the students on this list were randomly selected and there was no scientific basis for labeling them as "intellectual bloomers." However, the teachers did not know this and treated these students differently, giving them more attention, praise, and higher expectations. Amazingly, at the end of the academic year, the "intellectual bloomers" had indeed made significant gains in their academic performance compared to the other students in their class. This experiment demonstrates the power of teacher expectations on student performance and has led to increased awareness among educators about the importance of setting high expectations for students regardless of their starting point. It is worth noting, however, that the Rosenthal Effect has been subject to criticism, with some arguing that it is difficult to replicate the results in real-world settings and that other factors, such as student motivation and prior knowledge, can also influence academic performance. Nevertheless, the Rosenthal Effect remains an important area of study in education and a reminder to teachers of the significant impact they can have on their students' lives.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值