6485: Boxes and Candies(贪心)

6485: Boxes and Candies

时间限制: 1 Sec   内存限制: 128 MB
提交: 315   解决: 114
[ 提交][ 状态][ 讨论版][命题人: admin]

题目描述

There are N boxes arranged in a row. Initially, the i-th box from the left contains ai candies.
Snuke can perform the following operation any number of times:
Choose a box containing at least one candy, and eat one of the candies in the chosen box.
His objective is as follows:
Any two neighboring boxes contain at most x candies in total.
Find the minimum number of operations required to achieve the objective.

Constraints
2≤N≤105
0≤ai≤109
0≤x≤109

输入

The input is given from Standard Input in the following format:
N x
a1 a2 … aN

输出

Print the minimum number of operations required to achieve the objective.

样例输入

3 3
2 2 2

样例输出

1

提示

Eat one candy in the second box. Then, the number of candies in each box becomes (2,1,2).

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int main()
{
    long long n, x, a[100005];
    scanf("%lld%lld", &n, &x);
    for(int i=0;i<n;i++)
        scanf("%lld", &a[i]);
    long long ans=0, temp=0;
    for(int i=0;i<n;i++)
    {
        if(temp+a[i]<=x)
            temp=a[i];
        else
        {
            ans+=a[i]+temp-x;
            temp=a[i]-(a[i]+temp-x);
        }
    }
    printf("%lld\n", ans);
    return 0;
} 
/**************************************************************
    Problem: 6485
    User: ldu_reserver201701
    Language: C++
    Result: 正确
    Time:28 ms
    Memory:1752 kb
****************************************************************/

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

hhjian6666

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值