Given two strings S~1~ and S~2~, S = S~1~ - S~2~ is defined to be the remaining string after taking all the characters in S~2~ from S~1~. Your task is simply to calculate S~1~ - S~2~ for any given strings. However, it might not be that simple to do it fast.
Input Specification:
Each input file contains one test case. Each case consists of two lines which gives S~1~ and S~2~, respectively. The string lengths of both strings are no more than 10^4^. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.
Output Specification:
For each test case, print S~1~ - S~2~ in one line.
Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.
#include<iostream>
#include<string>
using namespace std;
int main() {
//while (1) {
string s, s2;
char c;
getline(cin, s);
getline(cin, s2);
while(s2.length()){
c = s2[0];
int i;
while ((i = s2.find(c)) != -1) {
s2.erase(i, 1);
}
//cout << s2 << endl;
while ((i = s.find(c)) != -1) {
s.erase(i, 1);
}
//cout << s << endl;
}
cout << s;
// }
}