2016ACM暑假集训 - Prime Ring Problem

Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 


 

Input

n (0 < n < 20). 
 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 
 

Sample Input

    
    
6 8
 

Sample Output

    
    
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2


解题思路:深度优先搜索,固定第一个为1,后面的为2-n,如果不符合条件救回溯。另外用一个数组储存是否是素数,加快速度



代码:

#include <cstdio>
#include <cmath>
#include <cstring>
int a[25];
bool use[25];
int n;

bool p[] = {0, 0, 1, 1, 0, 1,
			0, 1, 0, 0, 0,
			1, 0, 1, 0, 0,
			0, 1, 0, 1, 0,
			0, 0, 1, 0, 0,
			0, 0, 0, 1, 0,
			1, 0, 0, 0, 0,
			0, 1, 0};

void DFS(int num)
{
    if(n == num && p[1+a[n-1]])
	{
        for(int i = 0; i < n; i++)
		{
            printf(i == n-1 ? "%d\n" : "%d ", a[i]);
        } 
    }
    else
	{
        for(int i = 2; i <= n; i++)
		{
            if(!use[i] && p[i+a[num-1]])
			{
                a[num] = i;
                use[i] = true;
                DFS(num+1);
                use[i] = false; 
            } 
        }
    }
}

int main()
{
    int t = 0;
    while(scanf("%d",&n) != EOF)
	{
        memset(use, 0, sizeof(use));
        a[0] = 1;
        t++;
        printf("Case %d:\n", t);
        DFS(1);
        puts("");
    }
    return 0;
}






  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值